Loading...
 
Architecture / Installation

Architecture / Installation


GD: Not detected. or Imagemagick - Cannot Process Images.

posts: 4

cry

I have installed version 1.9.7 successfully and everything seems to be fine except the image processing functionality.
The admin page says that it cannot detect either GD or Imagemagick.

I am running RHEL4, with Apache 2 and PHP Version 4.3.9 (which came as a binary).

The phpinfo() shows:-

with-gd=shared' 'enable-gd-native-ttf' '--without-gdbm'

Im fairly sure these relate to gd rolleyes

I tried doing an rpm -qd gd* which gave me

php-gd-4.3.9-3.22.5
gd-2.0.28-5.4E

However I cannot figure out to get TikiWiki to actually recognise them ...

According to this page:-

http://doc.tikiwiki.org/tiki-index.php?page=Requirements+and+Setup#_Optional_Software_or_Libraries


"Use either GD Library 1.5 (or higher) or ImageMagick.
ImageMagick is included, by default with PHP 4.3+"

Which means that either I cannot see it or someone is wrong somewhere ...

Can anyone assist.


Thank you,


Max.

posts: 4

> Hi
>
> I have seen cases where GD is supposed to work but doesn't.
>
> Let's rule that out. Please install the attached file on your server and check if it works.
>
> I added to wishlist
> http://dev.tikiwiki.org/tiki-view_tracker_item.php?itemId=1347
>
> M ;-)


Hello,


I have now managed to get gd working - im somewhat confused as it is said to be bundled by default, yet it only got reconised by tikiwiki after did an up2date install for an rpm and restarted apache...

php -m on the cmd clearly shows is as being present.

I also have imagemagick installed and working (in /usr/bin), but tikiwiki cannot see it either.

Have you any idea why ... ?


Many Thanks.



Max.