Loading...
 
Architecture / Installation

Architecture / Installation


crash after upgrading to 2.1 from 2.0 (urgent help needed)

posts: 11

Hi,
My website crashed after upgrading from Tikiwiki 2.0 to 2.1 (using Fantastico Deluxe)

Here's what shows up on my website:

Call to a member function check_script() on a non-object in /home/amathlt/public_html/lib/setup/prefs.php on line 12

The first 12 lines of prefs.php are:

?php

// $Id: prefs.php 14126 2008-08-08 12:03:45Z ricks99 $
// Copyright (c) 2002-2007, Luis Argerich, Garland Foster, Eduardo Polidor, et. al.
// All Rights Reserved. See copyright.txt for details and a complete list of authors.
// Licensed under the GNU LESSER GENERAL PUBLIC LICENSE. See license.txt for
// details.

// RULE1: $prefs does not contain serialized values. Only the database contains serialized values.

//this script may only be included - so its better to die if called directly.
$access->check_script($_SERVER%22SCRIPT_NAME%22,basename(FILE));


please help,
Bob Klassen

posts: 1550 Canada

I suggest you do a manual install (not fantastico) of 2.2 and report back.

M ;-)


posts: 11
My server support restored an earlier version of my website. So my crisis has past. I'm wondering if the upgrade issue happened because I didn't close the website as a registered user first. I'll try the upgrade again next week.

posts: 11

After calming down a week or two, I used Fantasico to upgrade from 2.0 to 2.2 and it went flawlessly. Very nice.
thanks
...Bob
http://amateur-athlete.com