Loading...
 
Features / Usability

Features / Usability


Can't edit pages, "Toolbar set "Tiki" doesn't exist"

posts: 39

Try to create a new wiki page, error comes up saying "Toolbar set "Tiki" doesn't exist". I can click OK on the error, and click 'Save' to create the page, but when I try to come back and edit the page, the same error pops up.

Problem exists on IE7 (Windoze), Firefox 3.0.1 (Mac) and Safari 3.1.2 (Mac).

Tikiwiki version 4.2. I've seen workarounds posted, but they seem to be for older versions of Tiki.

posts: 39
Anyone?


posts: 39
Ah, that seems to be the issue. Switching off WYSIWYG gets around it. Thanks!

posts: 39

OK, this problem has come back. I accidentally clicked HTML in the tool bar and it tried to go into WYSIWYG mode. Now it's giving me the error again every time I try to edit a page. I've tried disabling WYSIWYG but the error refuses to go away. I cannot edit any pages!

Anyone?


posts: 39

I've tried looking through all admin settings and disabling anything that mentions wysiwyg. Tried in all browsers, can't edit pages anywhere.

Anyone?

posts: 153 Canada

When WYSIWYG is turned on, there is a default option that says "re-open the same editor" in other words, if the last time you edited that page was with WYSIWYG then you will get that error and Tiki will continue to try and open the WYSIWYG editor.

I've seen the error that you mentioned but only when both editors are ON. Did you say you are still getting this error only in Wiki Editor Mode with WYSIWYG turned off?

did you actually turn off the WYSIWYG feature from Admin->Features?


posts: 39
Ah, the Admin > Features is what I was missing. That doesn't appear for me in my admin menu. Now I've got it.