Loading...
 

Português


Calendário exibe letras "n" no início de cada linha

posts: 3

Olá colegas,

O módulo de calendário exibe algumas coisas estranhas, como essas letras "n" que aparecem no início de cada nova linha.
Image

Isso por si só já é bastante incômodo, sem contar os caracteres que não são reconhecidos.
Já olhei no template tiki-calendar_box.tpl mas não achei nada que pudesse estar ocasionando isso.
Será um erro de interpretação do Smarty?

posts: 52 Brazil

Olá Elton,

Qual versão você está utilizando?

Qual é o nome do módulo de calendário que apresenta o problema?

O problema com acentos ocorre apenas nesse módulo ou em outros locais também?

Me parece que você está olhando o template errado mas não tenho certeza. Templates de módulos geralmente ficam no diretório templates/modules e começam com o prefixo mod-

posts: 3

Olá Rodrigo,

Desculpe se não souber responder a todas as suas perguntas, mas aí vai:

A versão que estou utilizando é a 4.2

O módulo de calendário é o calendário do TikiWiki mesmo, tiki-admin_calendars.php, disponível na administração geral de módulos.
Quando incluo um novo compromisso no calendário, e clico encima dele, um pop-up aparece com essas informações. Esse pop-up é o que está no screenshot.

Até agora só tive problemas com acentos aqui, mas não consigo criar páginas wiki com acentos, acredito que isso seja normal.

O template acredito que seja esse mesmo, pelo que eu vi...

posts: 52 Brazil

Olá Elton,

Me desculpe, me confundi com a nomeclatura. No Tiki costumamos chamar de módulos as "caixas" que ficam na coluna da direita ou da esquerda. O que você está chamando de módulos costumamos chamar de recursos.

Começando pela última pergunta, sim é possível criar páginas wiki com acentos. Não sei porque não funciona na sua instalação. Talvez alguma configuração de enconding do servidor? Nas instalações que administro funciona sem problemas. Por exemplo: http://cappf.org.br/tiki-index.php?page=elei%C3%A7%C3%B5esdire%C3%A7%C3%A3o2010

Particularmente nos projetos que faço com Tiki nunca usei o calendário. Mas tentei e de fato existe um bug na versão 4.2 e ocorre exatemente como você descreveu. Porém testei também na versão 5.1 e ambos problemas (os misteriosos "n" e o problema com os acentos) estão resolvidos. Como a versão 4.x não é mais mantida, a melhor coisa para você fazer é atualizar para a versão 5.1.

Se isso não for possível e você tiver conhecimento de programação pode apenas fazer um backport do código que corrige os problemas em questão.

Espero ter ajudado.

Abraços, Rodrigo.

posts: 3

Rodrigo, muito obrigado!

Estava receoso com a possibilidade de precisar atualizar a versão...
Já estava postergando isso a algum tempo. Agora vejo que não tenho mais escapatória... biggrin

Abraços.


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.