Loading...
 
Architecture / Installation

Architecture / Installation


Issues with upgrading Tiki4.1 to Tiki6.6 LTS

posts: 1

Hello friends,

I'm trying to upgrade from Tiki4.1 to Tiki6.6 LTS (our site based on Tiki4.1 has been running a standard LAMP shared host for the last two years). I seem to have some issues with the upgrade. First of all, I was trying to copy my existing mysql database to a new one and to apply the upgrade on the new one (so that my existing site is not affected by this). Is there anything wrong with this idea?

Assuming that this is reasonable, this is what I did (following http://doc.tiki.org/tiki-all_languages.php?page=Upgrade):

* Create a new database and copy the contents of my old database to the new one. Select “utf8_general_ci” for “Collation”. Add the existing mysql user to the database.
* Reinstall the new version into an empty directory.
* Copy any custom files in img/wiki_up/, img/trackers/, templates/styles/ and styles to the new directory.
* Set the file permissions: chmod -R 777 ./db ./dump ./img/wiki ./img/wiki_up ./img/trackers ./modules/cache ./temp ./temp/cache ./templates_c ./templates ./styles ./whelp/
* Run tiki-install.php: Convert database and tables to UTF-8, Convert content from my previous encoding (latin1) to utf-8

In the last stages, I see that the installer has successfully read the settings from my old installation (for e.g., admin name, e-mail etc). But as soon as I click "Enter the wiki and lock installer" button, I get a blank page. I looked at the server error logs (through C panel), and I don't see anything there.

I'd be happy to provide any additional information. Any help would be greatly appreciated!

Best regards,
Ajith

PS: I have no issue with freshly installing Tiki 6.6 LTS on a new database on the same server.

posts: 1549 Canada

Try re-running the installer and in one of the steps, you can activate error messages.

Please also see Troubleshooting

Best regards,

M ;-)