Loading...
 
Architecture / Installation

Architecture / Installation


Can't log into my Tiki

posts: 40

All,
I'm running Tiki 9.1 as a work group collaboration site. It's been working really well for over a year. I last logged in on Oct 1st and everything was fine. Since then I've been taveling so haven't tried to log in until yesterday. Now I get the following screen —
"Tiki is unable to connect to the database
Things to check:

Is your database up and running?

Are your database credentials accurate? (username, database name, etc in db/local.php)"

I'm able to log into mysql and do show tables. All the tables appear to be there. I can access my BitNami welcome screen ( I'm using Lampstack for MySql and Apache installation) with no problems.

I've rebooted everything, but still can't get the login screen. I'm not seeing any errors in the Apache error_log or access_log files. Iptables is not running. The Linux admins say that nothing changed on the server.

Does anyone have any idea on how I can get to the Tiki login screen? My work group needs access pretty quickly as we're starting a new project in a couple of days.
Thanks,
Liz

posts: 40

Apologies to the Forum! I have found the problem — just typical isn't it, as soon as I post the question I answer it for myself.

For anyone else having this problem I fixed it by creating a symbolic link for mysql.sock in the /tmp directory pointing to the proper location which in my case is in the lampstack mysql/tmp directory.

The exact commands to do this are —
cd /tmp

ln -s /u01/app/lampstack-5.3.13-0/mysql/tmp/mysql.sock mysql.sock

( use your own location for mysql.sock of course)
You can search for mysql.sock by using the following command when you are in your mysql directory
find . -name mysql.sock

All this assumes that you have access to the Linux prompt

Liz

posts: 1562 Germany

Hi Liz,

yeah I know that aswell:

Think about a proper structured question, explain the problem in detail and post to the forum or mailing-list - guess what: know the answer right after posting in 90% of the cases.

Anyway, without proper structuring, I never had a chance to find out.

Thank you, that you post the solution straight away.

So I wish you more happy days with Tiki,
Torsten