Architecture / Installation

Architecture / Installation

"No route found" when editing tiki

posts: 1 USA


I've just installed Tiki 12.0 at clinicalcasefiles.com ; everything appears to have gone smoothly with the installation, except that now whenever I try to edit a wiki page it opens the editor appropriately after clicking "Edit Page", but then shows a page "No route found. Please see http://dev.tiki.org/url+Rewriting+Revamp" after clicking Save or Preview.

My hosting plan is the "Pro Shared Hosting" at namecheap (https://www.namecheap.com/hosting/web-hosting.aspx) with Apache/PHP5/MySQL I had previously used it to host an older Tiki version of this site without problems. I've been looking through the docs and the linked URL Rewriting Revamp page for several hours but am unable to figure out what this problem could be. I've tried several permission changes to tiki-editpage.php but that doesn't seem to be the issue. Any advice or insight about what's going wrong and how to fix it would be greatly appreciated!

Thanks a lot,
info at clinicalcasefiles.com

posts: 1 Singapore

I have the same issue with a clean installation of 12.0LTS (wiped out and recreated directory, databases etc). Used to be running on 9.1 with no issues.

Even saving an edited default HomePage is not possible.

Am I missing something fairly obvious given that it made it past beta?

I tried:

1. Turning off SEFURL completely.
2. copying _htaccess to .htaccess (as opposed to symlink)
3. Added following to route.php

function ($parts) {
return array('page' => $parts2);

posts: 42 Spain

I know this topic is old, but........ I have installed version 17.1 and I have the same problem.
"No route found. Please see http://dev.tiki.org/URL+Rewriting+Revamp"
I got this error mesage when I want to save some configuration or a modification in a wiki page.

This www.wikivitats.com is a link to a wiki page that has only three external links. If I put another external link and try to save, then I get the error, uffffffffffffffffff

Nobody knows the solution to this error?

Thanks and best regards

Santi Peralta