Loading...
 
Architecture / Installation

Architecture / Installation


Help! After upgrading to 9.7 LTS: All special characters are lost!

posts: 210

Hi!

I just upgraded my 6.12 LTS to 9.7 LTS. I installed clean, set the rights with setup.sh and started tiki-install.php and pointed it to my SQL database.

As instructed by tiki-install, I unchecked the box to force UTF-8, since I migrated from 6.12 LTS (it was checked, but the explaining text said it should be unchecked if coming from a previous version).

The content in my Tiki does contain special characters (german umlauts) which displayed just fine previously.

The script ran smootly, just one little error (one duplicate entry), so nothing big hapened. But the result looks terrible! All special characters are gone and replaced by some graphical symbol. All umlauts vanished, in hundreds and hundreds of articles!

Also, I cannot edit any pages anymore... Whenever I click on Edit anywhere (as Admin!) I get a blank code page...

Please help!
Thanks
Oliver

posts: 210
Add'l information: I have PHP 5.4 running on this shared webspace. I have shell access, but my PHP memory is limited to 90 MByte. I could activate PHP 5.5, that's an option I can toggle.
posts: 210

More trouble. The file gallery is broken. The gallery itself is there, the entire structure. After the clean install of 9.7 and before migrating the DB I manually copied the imagestore directory with all contents.

But when I click on any of the images in the file gallery, I only get this:

Strict Standards: Non-static method Image::is_supported() should not be called statically in /homepages/41/my_doc_root/htdocs/tiki/tiki-download_file.php on line 237

Strict Standards: Only variables should be assigned by reference in /homepages/41/my_doc_root/htdocs/tiki/tiki-download_file.php on line 322
GIF87ai Æ

So the "GIF87" tells me that the file was actually found and read - but not interpreted correctly?!? The rest after that is binary, probably the binary content of the GIF file inside a page...


posts: 92

I had the same problems. Someone else pointed me to these helpful pages.

https://doc.tiki.org/Upgrade#If_you_need_to_fix_the_encoding_issue
https://doc.tiki.org/Understanding+Encoding

Despite what it says about un-checking "enforce UTF-8 encoding" if migrating from a previous release, do not uncheck this box.
https://doc.tiki.org/dl343?display
What it should say is something like:
"Highly recommended for new installations and upgrades. However, if you are upgrading or migrating a database that has NOT been converted to use UTF-8 encoding, you are recommended to uncheck this box"

I did not run this:
https://doc.tiki.org/dl347?display

You can find my postings on these topics using the following links. It may be hard to follow, since I tried and failed a few times first.
http://tiki.org/tiki-view_forum_thread.php?comments_parentId=50424&topics_offset=5
https://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=50422#threadId4

posts: 210

Thanks,

that does sound familiar. In order to retry my tiki-install.php run I need to restore my DB to the state before. I have made a backup, and the ZIP file looks okay and does contain a SQL file which looks decent (I am not a DB expert), but phpmyadmin chokes on it.

I wonder if it is possible to simply re-run tiki-install.php, only this time with this box checked?

But I do not want to risk that unless I know I have a working backup...

Thanks for your help
Oliver

posts: 210

This did the trick!

Thank you so much. I still could not make my restore of the backup work (I figured phpmyadmin can save using Zip, but when restoring, it only takes gzip or bzip2) - the MySQL server always "went away" when loading the db. But since those SQL backups look decent, I took chances, and simply restarted tiki-install.php (but not before making another backup, of course...).

This time I "modified" the db connection. Entering all db access data again, and making sure the connection gets forced to UTF-8.

And - IT WORKS (sorry for yelling :-)

And this also solved two problems in one!... My special characters (German umlauts) are back again - and the page editing works again!

I thought this could be the second blocker, I thought my PHP memory would be too low, because the installer claims 128 MByte would be needed, and I only have 90, 1&1 (my hoster) doesn't give me more. But I doubted the idea, because even those blank edit pages claimed to have taken only 20 MBytes, so I did not believe PHP had run out of memory (also there was no memory error at all displayed).

Now everything works again (I could also make the file galleries work (clearing the Tiki cache solved that one). One or two files in the galleries seem to be broken now (but they are stored in the file system, not the db?!?, but I have backups of those).

So you saved my christmas eve tomorrow...

Thank you so much for your help.

Merry xmas!
Yours
Oliver