Architecture / Installation

Architecture / Installation

Fresh install/blank pages

posts: 11 United States

So after my success of installing Tiki on my Raspberry Pi (very slow to serve pages though, still it was fun), I was pumped to install it again on another machine with serious hardware. (background: windows guy here)


Ubuntu Server - 13.10
MySQL - 5.5.35
PHP - 5.5.3
Apache - 2.4.6

When I complete the Tiki install and click Lock Installer, I get a blank page.

If I delete the lock and redo the installer, verifying all settings are correct, still get the same blank page afterwards.

I've searched the forums here, tried a few things mentioned, no luck. I'm 99% certain it's not permissions related, at least on the Tiki folder. I explicitly set permissions there 777 and 644, like mentioned in the install docs.

Any help would be greatly appreciated. Thanks!


posts: 400

Hi - what version of Tiki?

On my host I seem to need to use 755 for directories. Permission errors usually show in error logs - you might look there if you haven't already.

posts: 11 United States

Lindon, thanks for the reply.

Can't believe I forgot to post my Tiki version. Duh.

12.0 is my Tiki version.

I should have been a bit more specific on my permissions too. 777 was for the directory, 644 was for files.

If I understand my Linux permissions correctly, 755 would actually be more restrictive for directories. So 777 proves it's not a directory permission issue correct?

I should also add, from troubleshooting docs located here, that my PHP.ini memory limit is set to 128M, I didn't change anything there, and the tiki-check and installer seemed to think that was ok.

posts: 400
You can get errors when permissions are too generous too. Anything in the error logs?