Architecture / Installation

Architecture / Installation

v10.5 to v12.0 Upgrade = Menus Not Linking Properly

posts: 7

I've got a working v10.5 tiki inhouse for over a year now (guessing, whenever v10 came out)... that I've upgraded to v12. The upgrade went seemingly perfect, everything is still there and all is well. Except the menu's do not seem to be generating properly and it's driving me nuts, I'm sure I must be doing something wrong... help?

Actual Page Name = My+Favorite+Tiki

Navigating to: http://wherever.com/My+Favorite+Tiki ...works as expected!

However, creating/editing menu option with URL of My+Favorite+Tiki is generating a link of http://wherever.com/My%2BFavorite%2BTiki (notice the %2B instead of +) and the Tiki or IE11 / FF27.0.1 isn't interpreting it correctly.

Any ideas?
- J

: updated :
My parenthesis are being interpreted by the forums, but I assure the double-parenthesis are there before and after the page names.

posts: 7

Just to be clear, everything works EXCEPT the menu...

The menus are linking to pages using %2B instead of + and and then Tiki is coming back saying My%2BFavorite%2BTiki doesn't exist... The menu option is in fact pointing My+Favorite+Tiki (which does exist). This is true for creating new menus and editing upgraded menus from v10.

I've been searching & searching, and see the URL rewriting/etc seems to have been a big deal (something I never had issue with in v10)... same server/install.


Not really sure what do do :-(
- J

posts: 214

The page name probably has spaces between the words, not plus signs. So use spaces in your wiki link: ((My Favorite Tiki)).


posts: 7

OMG, genious... lol! You have no idea how long I've been wracking my brain on this stupid problem!!

Alrighty, so in Menu > PageName...

Page Name = Page+Name (which works)
Page+Name = Page%2BName (which does NOT work)

And, in Pages themselves as links...

Page Name = Page%20Name (which works)
Page+Name = Page+Name (which works)

In hindsight, my menus in v10 all were Page+Name (worked) AND my page links were all Page+Name (worked)... so when my page links were working, I couldn't figure out wtf was up with the damn menus.

I'm good now, thank you so very much!
- J