Loading...
 

Documentation


Custom Modules Not Working In Tiki 13

posts: 24

Hi,

I recently installed Tiki13 and realized that custom modules don't work. I understand since 13 is new that's expected, I'm just wondering if anyone have a way to fix the problem. The most common problem with using custom module is the inability to edit wiki pages while the window is full-screen, interestingly enough, when the screen is resized to the point sidebar modules are relocated, you can edit the wiki.

I'm trying to add adsense on my site, I used a custom module before installing 13. I tried using the adsense module (Not custom), unfortunately I ran into the same problem (unable to edit wiki pages). Is there a way to possibly add the adsense code to the site without using a module, such as editing one of tiki's files. I'd like to put my ad code right after the wiki page content (Page Bottom). If anyone could help, that'd be great.


Thanks,
Nitreb

posts: 99

Hi Nitreb,

The best thing to do for this kind of question, is this:

Since you identified a bug, go to the dev portion of the site and submit what we call: Make a wish.

The url is: http://dev.tiki.org/Make+a+wish

You will get better service in that dev section by replicating the bug you observed than posting the question here on the forum.

Daniel.


posts: 1533

Hello nitreb,

I work with Tiki13 custom modules pretty much and I do not see a problem ... they are working.

There could be a number of reasons, like for example a non-closed div.

When I use custom modules, I frequently have issues with editing and transparent covered links or edit areas ... up to now that always have been issue which having been solved by reediting the content of the custom module ... usually PEBCAK (Problem Exists Between Chair And Keyboard) ;-) ... If you could give a bit more information, like a link to your site, an example of the adsense code (no username and no password, just an example how it technically looks like), I could give it a try to look into it.

Regards,
Torsten

posts: 24

Hi Torsten,

The code I'm using are old adsense codes from tiki12, it's unlikely that there's an unclosed div tag. I sent you my sites info to check the codes and errors to find out if the problem is coming from my side, if not, I'll write a bug report on the issue.


Thanks!
Nitreb

posts: 1533

Hi Nitreb,

the problem was caused by the quick_edit module in the page footer - not by the custom modules.

I played around a bit and editing wikipages works normal when you put the quick_edit module after the adsense module.

It seems, that when you put the quick_edit module directly after the page (in the pagebottom zone) that then somehow the module header "overlays" the editing area .. I have no idea how and why.

But anyway, putting a module in between page and quick_edit makes it working.

No idea what causes the conflict. Maybe a bug or maybe some selectors in the adsense.

By the way: the ads are not responsive.

Regards,
Torsten

posts: 24

HUGE thanks Torsten, you're right about custom modules working. The top ad module is working with no problem, the ones at the bottom (ad+quickedit) are the problematic ones, didn't have much time play around with them, so I removed them for now.


Enjoy the weekend!


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.