Loading...
 

Español


Traducir edicion de Wiki Link

posts: 16 Spain

Después de no conseguir traducirlo desde la administración he estado buceando un poco y encontré la manera de hacerlo manualmente, lo cuelgo aqui para quien le pueda valer.
Showing
El archivo a modificar se llama toolbarslib de tipo PHP, y la ruta para encontrarlo seria desde la raiz>lib>toolbars.
En este archivo esta también los botones y textos para tablas, enlaces externos,etc.. el de Wiki Link concretamente esta a partir de la linea 1116

Saludos

posts: 16 Spain

Con la traduccion interactiva no se puede, y tampoco dio resultado a traves de la administracion por medio de "añadir traduccion" esto ultimo admite las frases pero luego se realiza o no se ve el cambio. Yo no se casi nada de php pero me extraño que el archivo que toque no pusiera algo asi como include languaje o algo parecido, seguro que include languaje no es pero supongo entiendes lo que quiero decir. 

Lo de custom en la carpeta de languaje lo vi despues de solucionarlo, y la verdad como no se exactamente como funciona y ya lo tenia resuelto no le preste mucha atencion, si es factible hare desde ahi las traducciones que faltan para tablas, enlaces externos y el resto.

 


posts: 16 Spain

Devolvi el toolbarslib.php a su estado original para probar con custom, en este archivo solo edite la frase "Show this text", la ventana de Wiki Link seguia igual sin traducirse, comprobe en la administracion Editar idiomas>Editar traduccion haciendo una busqueda de "Show this text" y se mostro correctamente en los dos idiomas o sea se insertaron correctamente con el custom, pero aun asi la ventana de Wiki Link seguia mostrando el texto en ingles. Hice una limpieza de cache y volvi a probar con identico resultado.

¿tu lo tienes esta parte traducida en alguna instalacion Tiki? seria de gran ayuda saber en que archivo lo tienes traducido

Los pasos que segui para localizar ese texto fue descargar toda la instalacion, unos 15.000 al disco duro y luego con una distro de Zorin hacer una busqueda de texto dentro de los archivos. La descarga con mi conexion llevo algo de tiempo, la busqueda solo 2 o3 minutos

posts: 1777 Catalan Countries

Hola Juan Roberto:

 

Pues creo que has dado en el clavo, y esas cadenas no són internacionalizables (traducibles) ahora mismo sin tocar el codigo php directamente como tu has hecho. Por tanto, has tocado un  bug.

He preguntado ya en la lista de desarrolladores como arreglar esto (a mi se me escapa, con mis limitados conocimientos de php/js, ...

http://tiki.org/tiki-view_forum_thread.php?comments_parentId=55275

 

A ver qué dicen!

 

Saludos


posts: 1777 Catalan Countries

Hola Juan Roberto:

 

Ya está retocado el código de Tiki 12 (en r54444) para que esas cadenas de texto sean traducibles como las demás: vía custom.php, languages.php, etc.

 

Puedes coger el archivo modificado por subversion, o aplicar los cambios tu mismo en tu copia del archivo, siguiendo esta información:

http://sourceforge.net/p/tikiwiki/code/54444/

 

O esperar a la nueva version de Tiki12 (cuando salga), donde el archivo de toolbarslib.php ya está arreglado.

 

Ahora solo falta añadir las traducciones al language.php de Tiki14, 13 y 12.

 

Mira como hacer "commit" de los cambios tu mismo a la versión de desarrollo (actualmente Tiki14) y las otras mantenidas (13 y 12),  para que esten en las nuevas versiones oficiales de Tiki:

http://dev.tiki.org/Commit

 

Saludos

posts: 16 Spain

Bueno pues he detectado otro micro-bug en tiki-contact.

Si en anterior era que faltaban por hacer las traducciones, en este si es un verdadero bug,  y he comprobado que existe tanto en la version 12.3 como en la 13.1

$body = tr("%0 sent you a message:", $from) . "\n" . $body;

deberia comenzar por $body=tra al faltarle la A no realiza la traduccion a ningun idioma

Es obvio que se repara muy facilmente pero mejor es que este corregido en las subversiones 

PD: Me he lanzado a poner este mensaje antes de repararlo, me acabo de dar cuenta que añadiendo la A que supuestamente falta no se repara el problema, he limpiado la cache y reconstruido el indice de busqueda, pero el problema persiste

PD 2: he quitado la A que le añadi y ahora FUNCIONA CORRECTAMENTE  por lo visto me he hecho un lio yo solo  :( intentare reproducir el problema en otra instalacion de Tiki 


posts: 16 Spain
Ya baje el archivo y funcionando a la perfeccion, lo del commit es demasiado complicado para mi, mi dominio del ingles es solo un poco mejor que el de Tarzan, no creo que sepa hacerlo ni con la ayuda de San Google

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.