Loading...
 

LDAP / Active directory


Post LDAP Settings unable to login with Admin account

I was setting up my wiki with LDAP authentication (AD) based on https://tiki.org/forumthread48753 with my custom parameters. After I saved the changes and tried logging in - it did not work with LDAP ID. And now am trying to login with the admin id , the screen just goes blank. the server error says - PHP Fatal error: Call to undefined method UsersLib::ldap_sync_groups() in /var/www/html/tiki/lib/userslib.php on line 1468,. Kindly somebody help atleast that I can logon to the system.
Switzerland

Hi I am having the same problem, i was able to login to the system again by commenting line 1468 of userlib.php.

Change
$ret &= $this->ldap_sync_groups($user, $pass);

 

to
//$ret &= $this->ldap_sync_groups($user, $pass);

 

This will allow you to acess the page as admin again where you can remove the sync flag. How to actually make the sync work is still a mystery, it looks like the function is missing. Renember revert the changes in case you want to try again later.


Switzerland

Solution:

Go to lib/userslib.php and change line 1468 

from
$ret &= $this->ldap_sync_groups($user, $pass);

 

to
$ret &= $this->_ldap_sync_groups($user, $pass);

 

Make sure there is no group in your LDAP that already exists in tiki (eg i had a group named 'admins' that conflicted with a tiki built in group), once a user from the ldap log in the groups are created.

 

Hope this helps.

Hi, 

I encountered this same issue, where the function name had the leading underscore that caused a blank page when loggin in. However, after fixing that problem and logging in, I am getting an error on my main page that says "You do not have permission to view this page"

I have not been able to find a solution to this. Do you have any idea what is going on here? It appears that the LDAP isn't syncing the groups at all anymore. My guess is that is an issue with the ldap_sync_groups function in userslib.php, but I can't confirm this.

Any help would be great!

Also, I checked the system logs and its throwing this error:

Error: Bind failed: Can't contact LDAP server: Unknown Net_LDAP2 Error (-1) at line 237 in /data/web/htdocs/cewiki-dev/lib/auth/ldap.php

I'm trying to trace the error back to where it is originating, but the LDAP logs can get very congested. Will update if I find a solution.


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.