Loading...
 

Français


Besoins d'aide bug majeur mot de passe

posts: 9 Canada

J'ai copié mon wiki vers un nouveau serveur. Maintenant je suis incapable de me conecter sur mon compte admin et aucun autre compte d'ailleur.

J'ai tenté les commande sql proposé sur différent site sans aucun succes. On dirais que mon site se contente de refuser la conection sans meme lire dans la db. L'envoie de mot de passe a un email de secours ne fonctionne pas non plus.

J'ai fait la copie de l'ancien vers le nouveau serveur par copier des données, de la db et recréer les utilisateurs. L'ancien site fonctionne encore et j'ai tenté les commandes sql au cas que c'est moi qui les ferais mal mais fonctionne tres bien sur mon ancien site.

mon ancien site: www.uni-action.com/wki/tiki-login_scr.php
mon site qui ne fonctionne pas: http://158.69.209.250/~uniactionadmin/wiki/tiki-login_scr.php

Le site étant en test, j'ai aucune problème a donner des info de connexion en privée.

Je n'ai pas encore tenté de créer un nouvelle usager à partir du site web vue que la création de nouveau utilisateur est désactiver et que je peut pas le réactiver.

Merci d'avance pour votre aide.

posts: 97

Salut,

Ton nouveau site est-il vraiment connecté à la base de données ?
Plutot que de recopier le système de fichier en entier, préfère repartir sur un tiki neuf sur laquelle appliquer ta bdd. Copie seulement tes fichiers perso (images...)
De plus il semble que tu ai un problème avec la version de php utilisée :

PHP 5.5 is required
Your version: 5.4.45


hth

oliv'


posts: 9 Canada

Non il n'y a pas de problème avec la version de php utilisé. En fait, le changement de serveur est du au fait que mon ancien host ne permet pas d'utiliser zend guard avec php 5.5 ce qui m'oblige a l'aisser php 5.4. Quand je met 5.5 mon wiki fonctionne mais plus mon site principal.

C'est la raison pour laquel tu vois ce message, je dois laisser mon site principal fonctionnel.
Le problème que j'essaie de résoudre est sur mon nouveau serveur de test.

Si comme tu dit, le lien ne se fait peut etre pas avec la base de donnée, comment corriger ce probleme? J'ai déja vérifier dans le fichier local.php.


posts: 97

ok, autant pour moi.
Du coup, à re-vérifier :
- les permissions du fs (avec setup.sh)
- la redirection dans .htaccess (RewriteBase)
- db/local.php (en particulier la variable host_tiki si le serveur mysql n'est pas au même endroit que ton site de test)
Sinon, mieux vaut encore une fois tenter une installation fraiche de tiki, et ne n'importer la bdd qu'une fois cette installation fonctionnelle.
A toute,

oliv'


posts: 9 Canada

Comment on fait ces deux choses exactement:
- les permissions du fs (avec setup.sh)
- la redirection dans .htaccess (RewriteBase)



posts: 9 Canada

J'ai l'air bête un peu mais même avec la doc je n'y comprend rien....
J'ai installé en uplodant les donnée sur le server a partir du zip.

je sais pas comment lancé le .sh en ssh me donne un acces refusé donc...


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.