Loading...
 
Italiano

Italiano


Problemi di configurazione per db/tiki-db.php

posts: 13 Italy

Salve,
sto cercando di installare tiki sul mio sito( via FTP),
ho seguito fedelmente tutte le istruzioni riportate nella documentazione, ma mi sono imbattutto in uno strano errore:

Warning: mysql_connect(): Access denied for user: 'mionome@localhost' (Using password: YES) in /home/miaHome/public_html/tiki/lib/adodb/drivers/adodb-mysql.inc.php on line 318


Unable to login to the MySQL database 'nome_mio_db' on 'localhost' as user 'MyName'
Go here to begin the installation process, if you haven't done so already.
Access denied for user: 'mioNome@localhost' (Using password: YES)

MOLTO STRANO--> mioNome@localhost corrisponde al mio nome come utente del server e non al nome utente che ho creato per il Database


sospetto che il problema sia dunque in una errata configurazione di db/tiki-db.php, riporto quì la mia configurazione di /db-tiki.php

^

posts: 15 Italy

Ciao,

La tua configurazione non c'è, prova a rimandarla.

Poi, sai dire quand'è che appare l'errore? Quando apri tiki-install la prima volta? Sembra che tiki provi a far il login nel database come 'MyName' e non come 'mionome'...


posts: 13 Italy

questa e' la mia configurazione , nel messaggio precedente veniva troncata
dal sistema probabilmente per evitare che la macchina eseguisse il codice da me riportato,
dunque non riporto il tag di apertura di PHP e ometto il dollaro per le variabili( altrimenti non viene riportato niente...)

-> Apertura php

//api_tiki = 'pear';
api_tiki = 'adodb';
db_tiki = 'mysql';
dbversion_tiki = '1.8';
host_tiki = 'localhost';
user_tiki = 'nome_mio_db';
pass_tiki = 'passwird_mio_db';
dbs_tiki = 'utente_mio_db';

tikidomain = '';



l'errore di cui dicevo nel mio primo post, si verifica ad ogni esecuzione di tiki-index.php e persiste anche provando a configurare lo script attraverso il form tiki-install.php(quando provo a configurare tiki-db dal modulo non ricevo nessun output se non l'azzeramento dei campi da me inseriti), come ti dicevo il messaggio di errore, riporta un utente del db diverso da quello da me assegnato nella variabile $user_tiki e lo considera come Mionome@localhost..... decisamente strano!

Ciao e
grazie del supporto

_Andrea