Loading...
 

Architecture / Installation


500 Error on User Preferences Page

posts: 3 United States

My tiki wiki has started to have a weird issue. The User Preferences page now results in a 500 server error. I'm not sure exactly when it started. Probably sometime in December and I've spend the last month trying to figure it out. I know that it used to work but now doesn't. The file has the same last modification time as all the other files in the directory which was the install time. I was on tiki 17.1svn when it started and upgraded to 17.2svn as part of troubleshooting to no avail.

The error I find in the error logs is:

500 Server Error
End of script output before headers: tiki-user_preferences.php


I haven't been able to use that very constructively. I have had the professional admin/IT analyst of the shared hosting in use at my institution look into this and she couldn't figure it out either. Any idea why I get this error and why it would (to my knowledge) only occur on this one page? And most importantly any ideas on how to fix it?

posts: 581 United States

This started happening to me as well Jonathan, I have a bug submitted at https://dev.tiki.org/item6533
Feel free to jump in a leave comment at the bug as well. I have a little video demonstrating the error over there.


posts: 212

Unfortunately, I have also been getting the same 500 error on the User Preferences page for a while now, and I have not come up with a solution. But, I can add a little more information. Along with the Tiki site Access and Error log, I also find messages in /var/log/messages and /var/log/httpd/error_log that have the same time stamp as the Access and Error log file messages and are probably related to the error. (Space added after http: to keep them from being turned into links, the path to the site and the IP address have been replaced with ...).

_access_log:
"GET /tiki-user_preferences.php HTTP/1.1" 500 527 "http: //.../my" 500 527

_error_log:
[fcgid:warn] [pid 3751] (104)Connection reset by peer: [client ...:49650] mod_fcgid: error reading data from FastCGI server, referer: http: //.../my
[core:error] [pid 3751] [client ...:49650] End of script output before headers: tiki-user_preferences.php, referer: http ://.../my

/var/log/messages:
kernel: php-cgi[9912]: segfault at 7f39b1547000 ip 00007f39ae1765da sp 00007ffff120b928 error 4 in libc-2.17.so[7f39ae031000+1b8000]

/var/log/httpd/error_log
[fcgid:error] [pid 3951] mod_fcgid: process /home/.../fcgi-bin/php5.6.fcgi(9912) exit(communication error), get unexpected signal 11


posts: 5
Not sure if related, but my user preferences went out but with a PHP error generated. I debugged and found a PHP update on the server resulted in the 17.x code now failing. See https://dev.tiki.org/item6552 for a fix I made to the date code.
posts: 3 United States
I made those changes and it works now! That's fantastic! Not sure why it only effects that page though. So this is fixed but not solved.

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.