Loading...
 
Architecture / Installation

Architecture / Installation


Bitnami 22.1 installation Database Error

posts: 44

I logged the following error with Bitnami>

''The following message is reached when the installation is used, and I cannot work round it. I do not have or have learned shell access for an application within Windows.

Database Version Problem
Your database requires an update to match the current Tiki version. Please proceed to the installer. Using Tiki with an incorrect database version usually provokes errors. If you have shell (SSH) access, you can also use the following, on the command line, from the root of your Tiki installation: php console.php database:update

Steps:
Clean install of Windows Tiki 22.1
Login to Tiki
Choose Configuration Profile wizard
Apply Personal Blog and Profile''

Bitnami responded with

I reproduced your issue, but I think it is related to the Tiki application. They officially support MariaDB database, although not a max version is provided at https://doc.tiki.org/Requirements. We are using MariaDB 10.4, that is not forbidden in the linked docs (it says 10.1+). Can you ask to the Tiki developers about this?

So I am forwarding their question

posts: 1561 Canada

Thanks for reporting this.

That error message is usually for upgrades, not fresh installs.

We are using many recent versions of Tiki with MariaDB version 10.3 (via Debian 10) so I am very confident there are no issues here. I doubt there are changes between 10.3 and 10.4 that would cause errors.

Can you run the installer at tiki-install.php to see what the errors are?

If you don't apply the profile, is all OK? (Could also be an issue with the profile, but I don't see why it would cause a DB error)

posts: 44
Marc Laporte wrote:

Can you run the installer at tiki-install.php to see what the errors are?

If you don't apply the profile, is all OK? (Could also be an issue with the profile, but I don't see why it would cause a DB error)

The error still occurs if the profile is not run. I think when a new page is created the error message appears.

I have done a re-install of the database. This involved

  • deleting the lock file
  • finding the db name and password
  • re-running the install process.


This has led to a successful installation. I note that windows defender messages requesting permission for MySQL access and Apache2 access occurred, (granted). Perhaps the Bitnami installation should advise turning off firewalls during installation. I might try rerunning the installation with Windows Defender turned off.

The only annoyance that remains is an error message saying Invalid YouTube URL provided. This happened on every installation, but I "parked" that problem previously.

posts: 44
jpurssey wrote:

The error still occurs if the profile is not run. I think when a new page is created the error message appears.

I have done a re-install of the database. This involved

  • deleting the lock file
  • finding the db name and password
  • re-running the install process.


This has led to a successful installation. I note that windows defender messages requesting permission for MySQL access and Apache2 access occurred, (granted). Perhaps the Bitnami installation should advise turning off firewalls during installation. I might try rerunning the installation with Windows Defender turned off.

The only annoyance that remains is an error message saying Invalid YouTube URL provided. This happened on every installation, but I "parked" that problem previously.


The server test shows multiple problems. PDF of output attached.

However, the Personal Blog profile has installed successfully with no database problems. It does cause the Invalid YouTube URL error message