Loading...
 
Architecture / Installation

Architecture / Installation


Admin Login on New Install

posts: 122 United States

Hey everyone,

I've got a new install of 21.5. Everything works well through the install, but as soon as I start to navigate as the admin, I get an error message that I don't have the permission tiki_p_admin. I've checked in the database to make sure something isn't off, but the admin group does have that permission. I've tried deleting that line and manually adding back to the table, but I still have the same problem. At best I can sign in and navigate to a few pages, but then I get kicked out.

Any thoughts on what is causing this issue? I'm not even sure where to look. I thought maybe something was bad on the install, so I uploaded the files to another directory and created a new database, but it's still the same issue.

The only thing I can figure is something with my hosting, but I'm not sure what to check.

Thanks,
Greg

posts: 122 United States

I went through the action log and found that each time I get kicked out, there's a message that says system cookie validation failed.

I've been reading through the session and cookie documentation that I can find, but haven't been able to fix this.

The sessions are stored in /tmp, and there is write access to this folder. When I go in the folder there are a few files that were all created right about 30 minutes after I did the install. There is a .lock file, and I'm not sure if that's causing the issue or is normal.

Any thoughts on what I need to do? I've installed Tiki many times, and have never run into this issue.

Thanks,
Greg

posts: 122 United States

Sorry, I'm going to try one more time.

Does anyone have an idea what's happening here?

I've been playing around with Tiki, server, and browser settings for weeks and can't figure out how to get this to work. I've installed Tiki many times, and never have I run into this.

When I try to login as the admin I quickly get logged out with a message that says I don't have the right permission. Then when I log in, I get a CSFR message.

Any suggestions even on things to check?

Thanks,
Greg

posts: 1584 Canada

This is shared hosting, so there can be variations on how permissions are stored (to protect confidential info between various clients).

Try: tiki-admin.php?page=general -> General Settings -> Session storage location -> Database

So this will insure your sessions are stored in your database.

Greg Wheat wrote:
The sessions are stored in /tmp, and there is write access to this folder.

posts: 8542 Israel

Hello Greg,
(previous answer on Safari wasn't saved shorter one below) 😡

Sorry to read, I didn't saw other reports with such issue, it something on your hand I guess.
Of course, you flushed cookies and tried on incognito new browser window. ;-)

Install a clean Tiki 21.6 check if you have the same issue.
If you new install works, compare settings between the 2 Tikis and find what is causing the issue. See this tutorial : https://youtu.be/y5H5haNFCWI


posts: 122 United States

Thanks Bernard.

Yes I've tried clearing the cache. I've tried incognito. I've tried different browers, and different computers, and nothing works.

Yesterday I started with a new install of 21.6. I got the files uploaded, and when through the the install process, but I was only able to click through a few screens after signing in as the admin before I got the error again. It tells me I don't have the tiki_p_admin permission even though I do in the database.

Since I've made no other changes to Tiki, my assumption is I'm either setting a preference incorrectly during install, or it's my hosting provider.

Are there any settings that would cause this if set incorrectly on install? I don't think so, but wouldn't mind getting confirmation?

Also, any thoughts on the provider side? I'm running PHP 7.3, and MySQL 5.6.

Thanks,
Greg


posts: 8542 Israel

Hi,

Your database is ok and it work just fine on a brand new Tiki 21.6 I uploaded from release package. On your server, the PHPSESSION constantly expires and this leave you with a few second to work logged as admin.

Server Apache/2 Set-Cookie PHPSESSID=of070c0sgso30g9o19mlbp9dj6f51dcr; path=/; HttpOnly Set-Cookie PHPSESSIDCV=wr6m2MEgLbAkCo2JQEcMbg%3D%3D; expires=Tue, 03-Oct-2023 08:13:16 GMT; Max-Age=31536000; path=/; HttpOnly Set-Cookie javascript_enabled_detect=deleted; expires=Thu, 01-Jan-1970 00:00:01 GMT; Max-Age=0


Now and it is important to consider;

  1. I'm not Server Admin expert (I know pretty well my way to get Tiki working 😎)
  2. I had only access to your Tiki tools to make such diagnostic


I loaded https://c2gk.com/tiki-phpinfo.php and compared the "SESSION" section to other Tiki I have. I believe something is wrong about the path OR the permissions of the tmp directory where are (should be) stored the sessions. Hard to say more without shell access.

I couldn't attach or upload a screenshot so...
https://ibb.co/MZqhkQC

posts: 122 United States

I've still haven't figured this out. Over the last few weeks, I've been going back and forth with the hosting company. They insist there are no issues on their side, and it's with Tiki. At first I wasn't so sure about that because I have to believe others would be having the issue, but I remembered I had an older version (17.1) also on the hosting, and it works. So I think it may be an issue specific to my hosting provider, but also with the newer versions of Tiki.

I checked the phpinfo settings for that install, and the session.save_path has the same values for local and master. In both cases, it's the /hermes/phpsessions/. With the 21.6 install that I've been trying to get working, the local is /tmp. Any idea where that can be updated so that it matches the master? In the general settings, the session storage location is Default, but that doesn't seem like it's working.

Thanks,
Greg