I have just installed TikiWiki (latest version as of today's date), and have twice come across the error messages at the top of the page that included the message in the header above.

I re-configured my CPanel site to DISABLE PHP5, and the error message went away. So this appears to be a problem associated with PHP 5.