Loading...
 
Architecture / Installation

Architecture / Installation


error html_entity_decode' is not implemented

posts: 26

I'm getting the following error when saving a wiki page after upgrading.

Fatal error: Smarty error: in mail/user_watch_wiki_page_changed.tpl line 34: plugin modifier 'html_entity_decode' is not implemented (core.load_plugins.php, line 118) in /var/www/html/tikiwiki-1.9.0/lib/smarty/libs/Smarty.class.php on line 1088

By pressing the back button and then pressing the "Save" button again it works without error.


Running in test environment before upgrading

  • Installed new wiki code
  • Pointing to a copy of my database
  • ran the 1.8to1.9 upgrade sql script


Any ideas?

posts: 1551 Canada

I had the same problem.

It is caused by html_entity_decode not being supported in PHP before version 4.3

Look for this file:
templates/mail/user_watch_wiki_page_changed.tpl

You will see html_entity_decode 3 times:

Example:Image
{$mail_diffdata[ix].data[iy]|strip_tags:false|html_entity_decode}


Remove the 3 "|html_entity_decode". Example:

Image
{$mail_diffdata[ix].data[iy]|strip_tags:false}


Best regards,

M ;-)

posts: 26

That fixed the problem. I'm running PHP 4.2.2. Do you know of any other compatibility issues that I might run into.

Thanks for taking the time to post a response.

2
-- C --

> I had the same problem.
>
> It is caused by html_entity_decode not being supported in PHP before version 4.3
>
> Look for this file:
> templates/mail/user_watch_wiki_page_changed.tpl
>
> You will see html_entity_decode 3 times:
>

> Example:Image
{$mail_diffdata[ix].data[iy]|strip_tags:false|html_entity_decode}

>
> Remove the 3 "|html_entity_decode". Example:

> Image
{$mail_diffdata[ix].data[iy]|strip_tags:false}

>
> Best regards,
>
> M ;-)

posts: 1 Germany

> Remove the 3 "|html_entity_decode". Example:

> Image
{$mail_diffdata[ix].data[iy]|strip_tags:false}


This breaks the 'monitor this page' feature. Better fix:

Place the PHP_Compat package in /usr/share/pear/PHP and
add the following 2 lines to tiki-setup.php

require_once ('PHP/Compat.php'); PHP_Compat::loadVersion();


Works for me with PHP 4.1.2

Michael