Loading...
 
Features / Usability

Features / Usability


File Galleries > Search Indexing > Missing Handlers application/vnd.ms-office [Resolved]

posts: 19

Hello,

I have the famous problem with mimetypes described here: http://dev.tiki.org/item4280

It about old office documents that are uploaded as application/vnd.ms-office

Anyone have a solution or a fix ?

Thanks for your help.

posts: 1550 Canada

Hi!

I think we have a solution that works, but I can't personally see it on my systems (and thus, I can't test the fix)

  • Can you do a test upgrade (on backup data) of the Daily Build of 9.x?
  • If that doesn't work, use Server Check to make sure you have "fileinfo". If not, install that or ask your web host.


Thanks and best regards,

M ;-)


posts: 19

Hello Marc,

I installed files from diff archive available in sourceforge. and it works now !
Office files like .docx are now detected with MimeType application/vnd.openxmlformats-officedocument.wordprocessingml.document.

Thank you.

posts: 1550 Canada

So they are detected correctly: super!

But what do you use to index them (for the content to appear in the search results)?

Thanks!



posts: 19

Hello Marc,
sorry for the delay.

Where can i add the needed code and how, i tried to commit to sourceforge svn but since i'm not a member, it was rejected..

'application/vnd.openxmlformats-officedocument.spreadsheetml' => array('xlsx2csv.py %1'),
'application/ms-powerpoint' => array('catppt %1'), 'application/vnd.openxmlformats-officedocument.presentationml' => array('pptx2txt.pl %1 -'), 'application/msword' => array('catdoc %1', 'strings %1'),
'application/vnd.openxmlformats-officedocument.wordprocessingml' => array('docx2txt.pl %1 -'),

Rgds



posts: 19
yep! it was me, i tried to commit code :-)

posts: 19

Hello Marc, my account is in sourceforge is d0cster with 0 not o ;)

Rgds.