Loading...
 
Architecture / Installation

Architecture / Installation


Upgrade from 5.1 to V9.3 Syntax Error

posts: 8

This is wierd, I am surprised.. The error I got is.
Parse error: syntax error, unexpected T_FUNCTION in /appl/www/live/collabv10/installer/schema/20120904_category_root_tiki.php on line 22

when I look at the php file, I dont see an error in the syntax. and no one else has reported it.
Any suggestions?


posts: 2428 Czech Republic
I am surprised too. Maybe your CLI php has some limitations which does not like the table() function ? Can you try run the upgrade via the Tiki installer in your browser (that should use the sql file schema iirc) instead of from command line ?

posts: 8
Found it, my PHP is version 5.2 and the Anonymous function was introduced in Version 5.3 so this is the error, during the install. so I need to upgrade the php to fix this problem.

Upcoming Events

No records to display

Menu