Loading...
 
Features / Usability

Features / Usability


Re: Fatal error while trying to rebuild search index

posts: 44 Canada

The reason why you are getting this error is most likely because your PHP version is less than 5.5, which is the minimum PHP requirements of Tiki version 14 (see https://doc.tiki.org/Requirements).

If you upgrade your PHP to 5.5 or higher it should work fine. Note that depending on your server, the web version of PHP as shown in tiki-phpinfo.php (or alternative phpinfo()) could be different from the one used on the command line (shown using php -v).

If you switched to MySQL Full Text Search as the engine for Unified Search, you will still need to rebuild the index before it can be used, but I think you will need PHP 5.5+ nevertheless for Tiki 14 on the whole, otherwise you will run into many unexpected issues.