Features / Usability

Features / Usability

Can't modify global permissions as admin

posts: 27 Indonesia

Hi all:

In a TW14.0 installation (fresh from few days ago), logged in as Admin, I could set up the global permissions and category permissions without problem.

Today I had to change some global permissions, and
1) I can open tiki-objectpermissions.php
2) I can tick the permissions I need (in this case tiki_p_view_trackers)
3) I click assign

Then the global permissions are not set, they remain the same.
No error message sown, just the permission table remains unmodified.
Cache was cleaned and tried again. Same issue.

I went to table users_grouppermissions and could add the permissions manually via phpMyAdmin, and later on I saw the global permissions as ticked in iki-objectpermissions.php, but I don't want to mess with teh DB via phpMyAdmin (it was just a proof of concept, to see where the issue was)

Any other detail I should check?

In general: Can global permissions be modified once the category permissions have been set? Or once the category permissions are set, better don't mess with global permissions?

Many thanks,

posts: 27 Indonesia

After further checks it was caused by max_input_vars too low in php.ini

changed this max_input_vars for a higer number and worked again.


Upcoming Events

No records to display