Loading...
 
Features / Usability

Features / Usability


Re: Yikes.. help appreciated

posts: 3

cry don't panik... in my case it is "happy end" (for the moment...)lol

I have just encountered the same situation! It is a bit hard to make an idea of what can provoke the corruption... I have just finished to migrate my Debian Woody server to "testing" (sarge). I update mysql from 3.2x to 4.0. After observing the tiki working without any problems (just restarting services, no reboot), I conclude everything OK! (and I let down my databases backup... :-()

a few after, I tried to create a backup in tikiwiki, that FAILED!
After that I have been logging a few on the server and ... CRASH evil

I have no idea of a tool that can analyse back the .MYI, .MYD files. because in my case the files are still there and seems to be OK (maybe too small because the wiki part have been filled reasonably and the files still only :
76K tiki_pages.MYD
44K tiki_pages.MYI
is it possible to store ~20-30 "normal" pages in such a size?
(instead of 4K for an empty table)

neither the site was not filled a lot, I am feeling very sad and bored at the idea to start again...
I tried to dump my tiki database to check if other tables are also corrupted and only tiki_pages seems bad. in the worst case, can I try to start the system as it is and with an empty tiki_pages table. I am afraid the system need at least the HomePage and maybe some more...

found that reference that I start to readeek
http://dev.mysql.com/doc/mysql/en/Repair.html


useful: shell> perrno ###

errno 145 = Table was marked as crashed and should be repaired rolleyes (I hope they are so optimist not just to look fine...)

hormigaga:/var/lib/mysql/tiki# myisamchk tiki_pages.MYI

Checking MyISAM file: tiki_pages.MYI
Data records: 15 Deleted blocks: 0
myisamchk: warning: Table is marked as crashed
myisamchk: warning: 1 clients is using or hasn't closed the table properly
- check file-size
- check record delete-chain
- check key delete-chain
- check index reference
- check data record references index: 1
- check data record references index: 2
- check data record references index: 3
- check data record references index: 4
- check data record references index: 5
- check record links
MyISAM-table 'tiki_pages.MYI' is usable but should be fixed

vamos un poco mejor... yes it worked for me !!!

here the log:

  • myisamchk -e *.MYI

//actually the result was the bad for all tables (ver. 3 --> ver. 4 ?)

MyISAM-table 'name_of_table.MYI' is usable but should be fixed
  • backup the data: cp -r /var/lib/mysql/tiki somewhere
  • myisamchk -r *.MYI


everything is very well explained and illustrated in the page I linked above.