Loading...
 
Themes

Themes


Visibility Issues in FIVEALIVE (Standard, Blue-White): Forum & Dropdown Menu

Dear all,
after no reaction in the German forum I hope this one is read by one or another developer or experienced user who can help me.

After dropping an attempt to install TikiWiki some years ago (V 14 back then) I have started a new installation with V 20 - and TikiWiki has improved a lot since!

I have only a handful of small issues and I'm almost sure that most of them can be solved easily. Two Issues are associated to the visibility of information - and saying this I think I am right with these in the "themes" forum. :-)

I have chosen FIVEALIVE (as mentioned in the topic) in the Standard color setting, which looks quite good. The old site is also white/blue, so the colors are familiar to my community users. Okay, the form fields would look better in a light yellow instead of light pink, but that's really just my personal point of view. No problem to work with.

Wiki, Blogs, the Forum and thread overview - all looks fine. But if you open a thread you see... white text on white ground. If you mark with the mouse you see the text. If you don't you think, the text is missing.

A similar problem occurs in the own User Profile. You have My Tiki, Settings, About me, Watched Items (?) and a dropdown menu "More". If you open this menu the entries are blue text on blue ground...

Now the core question is: How to solve such issues?

I have found the form for "User defined CSS" in "Look & Feel", when the configuration is set to advanced... but that is like sitting in a 747 without a training or manual. And https://themes.tiki.org/Modifying%20a%20theme is... empty.

So I'm still lost...

Thanks for your help and
best regards
Uli

Just recognized that one of the mentioned errors can be found on this site as well (inside the green circle):

Menu User Section

Best regards
Uli

Japan
Uli wrote:

Just recognized that one of the mentioned errors can be found on this site as well (inside the green circle):

Menu User Section

Best regards
Uli


This problem isn't related to the post title color issue. The HTML of the My Accounts "More" dropdown menu wasn't updated from Bootstrap 3 to 4. I just submitted a fix for that, which will be in the next Tiki release. Thanks for pointing out the problem. :-) .

-- Gary

Thanks, Gary!
That's quick enough for me. My timeline is to update to 21 LTS before GoLive.
Just the test team needs to access before - and they will need to live with this menu as it is.

Best regards
Uli


Japan

A fix was submitted for this problem in the trunk development version and branch 21 version of the Tiki files but the fix isn't in a released version of Tiki yet. In the meantime, custom CSS can be added on the Look and Feel admin page but I don't have the specific info on hand (I'm away from home just now, and will post another message with the CSS to use after I double-check the details).

-- Gary

Japan

About the post title, etc. text not being visible, this can be added to the Look & Feel custom CSS:

.blog-postbody-title, .blog-postbody-title a, .postbody-title .title > .card-title a.link, .postbody h2.card-title {
    color: inherit;}

The problem has been fixed in Tiki's development files, but this temporary fix should do the trick until your site can be updated.

-- Gary

Thanks for fixing this in the code for the next release.

Unfortunately the workaround via Custom CSS seems not to solve it. :-(
To me it looks a bit strange that CSS changes for the forum/bulletin board start with .blog - is that correct?

Best regards
Uli


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.