Loading...
 

Tikiwiki-devel (mailman list mirror)


Composer deprecation warnings

posts: 126261

Hi Luci and all

I just added this:

https://dev.tiki.org/item7021-Make-Tiki-20-compatible-with-Composer-2-0

I think it's solvable for Tiki 20+ by renaming and moving everything around (will be complicated a bit by our use of satis and composer.t.o) and hopefully we can find a way of keeping the old branches going once this happens...

Please add comments and improve with any ideas or plans :-)

jonny





> On 30 Jan 2019, at 13:44, luciash <luci@tiki.org> wrote:
>
> Hi,
>
> today I get lot of Composer deprecation warnings. What can we do about it:
>
> Deprecation warning: require.Sam152/Javascript-Equal-Height-Responsive-Rows is invalid, it should not contain uppercase characters. Please use sam152/javascript-equal-height-responsive-rows instead. Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.chartjs/Chart.js is invalid, it should not contain uppercase characters. Please use chartjs/chart.js instead. Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.christian-vigh-phpclasses/PdfToText is invalid, it should not contain uppercase characters. Please use christian-vigh-phpclasses/pdftotext instead. Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.ckeditor/ckeditor/skins/bootstrapck is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.ckeditor/ckeditor/skins/minimalist is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.ckeditor/ckeditor/skins/office2013 is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/anythingslider is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/async is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/colorbox is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/fitvidjs is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/galleriffic is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/infinitecarousel is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/jquery-json is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/jquery-validation is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/media is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/nestedsortable is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/reflection-jquery is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/superfish is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/tagcanvas is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/treetable is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require.jquery/plugins/zoom is invalid, it should have a vendor name, a forward slash, and a package name. The vendor and package name can be words separated by -, . or _. The complete name should match "a-z0-9(_.-?a-z0-9+)*/a-z0-9(_.-?a-z0-9+)*". Make sure you fix this as Composer 2.0 will error.
> Deprecation warning: require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead. Make sure you fix this as Composer 2.0 will error.
> Updating to version 1.8.3 (stable channel).
>
>
>
> ___
> TikiWiki-devel mailing list
> TikiWiki-devel at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel
>



___
TikiWiki-devel mailing list
TikiWiki-devel at lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/tikiwiki-devel

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.