Loading...
 
Features / Usability

Features / Usability


.csv import with complex trackers does not work

Ukraine

Has anyone had success uploading to a complex tracker? Meaning one with many fields and a full variety of fields (i.e. a monster tracker)

Based on my initial success of exporting / importing with simple trackers (meaning just a few fields & mostly text fields), I went ahead and created several 'monster' trackers - but really, for any business who's goal is gathering and manipulating data, I would almost say they are pretty standard.

And, just before posting this, I went ahead and tested one of my simple trackers again - exported, added an entry, uploaded, and all works perfectly.

I've spent probably at least 60-80 hours of my life on this (over many weeks), trying many, many variations, assuming I am doing something incorrect. But I'm coming to the conclusion, that I am overwhelming Tiki, which could mean it is not appropriate for business use if import / export does not work.

Here is some background:
- Tiki 12.3
- two of my key larger (i.e. monster) trackers contain about 50 fields each
- full variety of fields (auto increment, drop-down, item link, dynamic item list, mathematical calculations (many), date & time, text, headers, checkboxes, etc.)
- a new manual entry in the tracker form on a wiki page works good
- I've eliminted the dreaded 'static text field' as it just screws up export (many colums are mis-aligned when opend up as .csv in LibreOffice)
- multilingual (English / Ukrainian) field names (though all default to something like 'f_485' so I don't see a problem here)
- multilingual (English / Ukrainian) content within the fields

The key difference between my successful simple tracker uploads and the unsuccessful complex ones is that the complex tracker upoads always say at the top:

"Import complete with Duplicate Header names"
Duplicate Header Names
and, of course, zero files are uploaded (or modified)

-though I have aligned all the field names so there are no duplicates, &,
-even tried simply exporting, changing one word in one field, and immediately importing, but no success (both Libre Office and gedit, & changed file name 'number' to '0')

Seem to have also tried all possible variations of the three check-boxes at the bottom of the import screen Three Options At Bottom

Since it is affecting two completely separate trackers I'm hesitent to think that 'rebuilding' one from zero would work (also I have 'Duplicated' a tracker, imported the 'structure', realized all the header numbers have changed so addressed this, but without import success).

And this all started simply to populate the tracker so close to 2000 street names would 'Autofill' vs. 'Item Linking' them from another tracker!

Thanks,
Mike

Ukraine

add another 5 hours on the pile, no success yet :-)

Also discoverd exporting isn't so easy with large files. Thought I did it before, but realized I just cleared the database and uploaded another .csv file (originally from excel).

I have a database of addresses with 4283 entries, only 2724 (+header line) export.

Don't thinks its memory limits of my web host, don't seem to be runing up against any limits according to the stats. (192 php memory limit). Also, I was able to upload  the full file before.

Tried changing 'Admin > Performance > Time and Memory Limits > Memory limit to apply during tracker item export' (was not set) to 256M, 512M, 128M, but all changes just exported even less.

Tried both the exporting options - Quick and detailed (Export Tracker Items), no difference.

What did I miss?

Thanks,

Mike


Upcoming Events

1)  Wed 23 Sep 2020 14:00 GMT-0000
September TRM

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.