Loading...
 
Features / Usability

Features / Usability


How to export single Wiki page as PDF in 18.4

posts: 7

Hi,
I'm looking for a convenient way to export single Wiki pages as PDF. I'm using the latest LTS version 18.4. Any hints?
Thanks in advance!

posts: 7
Rick Sapir / Tiki for Smarties wrote:

You could:


HTH,

- Rick | My Tiki Blog | My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.


Thanks a lot Rick. I've tried to follow the way with the mPDF. Unfortunately, composer was not installed. I've tried to install it as described via the setup.sh script, but now ended up in my whole tiki wiki not showing any pages a lot of times. Only sometime, loading works. Not sure what I broke :-(
Attached is the cli output for my attempt to install it. Any ideas what the issue could be?

posts: 2238
Wolfson wrote:

Thanks a lot Rick. I've tried to follow the way with the mPDF. Unfortunately, composer was not installed. I've tried to install it as described via the setup.sh script, but now ended up in my whole tiki wiki not showing any pages a lot of times. Only sometime, loading works. Not sure what I broke :-(
Attached is the cli output for my attempt to install it. Any ideas what the issue could be?


Hi,
from the cli output it looks to me that the last command bash ./setup.sh -p php7.3-cli composer worked (somehow). Didn't it? Anyway, I would try:
sh ./setup.sh -p php7.1-cli composer

HTH,
luci

posts: 7

Thanks luci for checking!

Meanwhile I've checked a few things. Short story is: When using a Tiki Install based on the tar-ball, everything works fine on the server. As soon as I use an install based on the svn-repo, and thus by means of using the composer, tiki hangs after a few clicks. Then, the homepage does not work anymore as well. I guess it's related to some php issue.

I did set up a system in VirtualBox that is as similar as possible to my webhosting server environment (Debian 8, Apache/2.4.10 (Debian), mysql Ver 14.14 Distrib 5.5.62, php 7.3) and checked everything there. Every install runs fine, also the one based on composer. I then put everything in a git repo, pushed it and pulled it from the webhosting server.

One thing that is strange though, my config tool from IONOS (1&1) tells me that php7.3 is active for this subdomain. However when running
php --version
via ssh on the server I get the following output:
PHP 4.4.9 (cgi-fcgi) (built: Aug 29 2019 12:59:15)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies

I guess this could be the problem, right? So do the tar-ball based files run fine based on this old php version but after installing the composer something crashes due to this old version?
For the version stuff I'll contact the support...


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.