Loading...
 
Architecture / Installation

Architecture / Installation


Forum Reply Error $_POST["thread_sort_mode"]

posts: 1

I set up a TikiWiki forum about two weeks ago and I can't find a solution to this problem after numerous searches and permissions adjustments.

When logged in under the admin account, I can post and reply to any topic or post in any forum.

However regular Registered Users can only reply to a post using the reply button by the topics original author. If the user should use any other reply button they will get this error:

Notice: this variable may not be empty: $_POST%22thread_sort_mode%22

I even gave the Registered Users group admin permissions and that did not fix the problem.

Has anyone run into this error?
Is this a new, current or old error that will be fixed by an update or permissions change that I missed?

Any help would be welcome as this current error makes my TikiWiki forums nearly unusable.

posts: 10

I also have this problem.
Using TikiWiki 4.0.


posts: 5
Same problem with my installation

posts: 5

This page has the same problem. You can not post by the "Reply" button.

The direct cause is this:

input type="hidden" name="thread_sort_mode" value=""

You may try to modify the comments.tpl, to assign it to "commentDate_desc" or so to have a work around.


But some how on other forum topics, I saw this was fixed. Could not find that page at this moment.


This bug is fatal to forum feature. Should be addressed in highest priority.



posts: 5

Here is the comparison, is this a problem when create a new forum?
Then what's the difference of these 2?

This one works:

Forums » Development » bug - Last Forum Posts is empty for posts in restricted forums
http://tikiwiki.org/tiki-view_forum_thread.php?forumId=3&comments_parentId=35853&thread_sort_mode=commentDate_asc

But this one doesn't,

Forums » Architecture/Installation » Forum Reply Error $_POST%22thread_sort_mode%22

http://tikiwiki.org/tiki-view_forum_thread.php?topics_offset=1&forumId=6&comments_parentId=36043


posts: 45 Germany
Same problem here. Please fix it!!! Works for admin users without problems, but not for normal users.

posts: 45 Germany

What exactly do I need for workaround enter?
I don't understand

''This page has the same problem. You can not post by the "Reply" button.

The direct cause is this:

input type="hidden" name="thread_sort_mode" value=""

You may try to modify the comments.tpl, to assign it to "commentDate_desc" or so to have a work around.''


posts: 8

samw prob :-((

pls help


posts: 5 France

The workaround method posted by mm2cat can be done by editing the templates/comments.tpl file and replacing the line 292 :



by this one :





hope this helps...


posts: 5 France

The workaround method posted by mm2cat can be done by editing the templates/comments.tpl file and replacing the line 292 :

<input type="hidden" name="thread_sort_mode" value="{$thread_sort_mode|escape}" />

by this one :

<input type="hidden" name="thread_sort_mode" value="commentDate_desc" />

hope this helps...

(could not edit the previous message because of this precise bug)

posts: 15
can someone do that to this site so I can post forum replies?

posts: 5
Excellent! It works!

posts: 3

Good day! My small patch ^) May be it work:
kido:/var/www/lan# diff -u ./tiki-view_forum_thread.php.orig ./tiki-view_forum_thread.php


+++ ./tiki-view_forum_thread.php 2010-04-07 14:19:03.824307680 +0400

@@ -70,6 +70,8 @@
} else {
$quote = 0;
}

+ +

$smarty->assign('quote', $quote);
$comments_parentId = $_REQUEST%22comments_parentId%22;
if $_REQUEST%22openpost%22 {
@@ -213,8 +215,24 @@
//print_r($thread_info);
$smarty->assign_by_ref('thread_info', $thread_info);
$comments_per_page = $forum_info'commentsPerPage';

+ +if (isset($_REQUEST%22comments_per_page%22) && $_REQUEST%22comments_per_page%22) { + $comments_per_page = $_REQUEST%22comments_per_page%22; +} +

$thread_sort_mode = $forum_info'threadOrdering';

+ +if (isset($_REQUEST%22thread_sort_mode%22) && $_REQUEST%22thread_sort_mode%22) { + $thread_sort_mode = $_REQUEST%22thread_sort_mode%22; +} + +

$thread_style = $forum_info'threadStyle';

+ +if (isset($_REQUEST%22thread_style%22) && $_REQUEST%22thread_style%22) { + $thread_style = $_REQUEST%22thread_style%22; +} +

$comments_vars = array(
'forumId'
);


posts: 3
Sorry formatting, I don't know how.

Upcoming Events

1) 
TikiFestFosdem2023

Menu