Loading...
 
Architecture / Installation

Architecture / Installation


[resolved] Tiki Installer Security Precaution loop when installing

posts: 4

Update: This was resolved with the help of the user xavi in the tiki IRC chat room. After talking through the issue and suggesting a few trouble shooting options, a solution was found.

My web host offers a variable for the database host name, but the installer wouldn't accept that. I tried creating a local.php file myself to put the details in, but that triggered the loop. I recalled that some time ago I had a problem with installing some other server software and my host provided me with a static address for the particular server on which my databases are stored.

After removing the local.php file I created I was able to get back into the installation process and I used the database address given rather than the variable or localhost. This was enough for the installer to find, and the install process completed.

Thank you to xavi and to the tiki community for running a support IRC channel!

-----

Hi, I'm trying to install tikiwiki and have run into some problems, but I've run out of ideas for this one.

I've had to manually create the local.php file to get it to work. The auto install process fails by getting into an infinite loop on the Tiki Installer Security Precaution page. I am using the correct database username and password. I've checked that the session temp folder is correct and tikiwiki has permission to write to it. The most recent session file contains this: install-logged-|s:1:"y";

I tried following the manual installation procedure as described here http://doc.tiki.org/Manual+Installation?bl=y and the database import went successfully. All of the tables have been created. Yet the site still reverts to the installation.

I tried accessing tiki-admin.php directly but it diverts me back to the instillation page whereupon I'm back in the loop. I'm at my wit's end and I don't know what to try next.

I'm installing on my web site hosted at mediatemple. I'm installing version 13. My PHP is version is 5.5.6. MySQL version is 5.1.26-rc-5.1.26rc-log - (Debian)

Can anyone offer any help resolving this? Thank you!