Loading...
 
Architecture / Installation

Architecture / Installation


Edit Pages Are Blank After Upgrade

posts: 11 United States

I'm currently on version 12.0 (yes, I know I need to upgrade to 12.2, I'm getting there :-).

I recently upgraded my Ubuntu server from 13.x to 14.04. After the upgrade, whenever I try to create a new page, when the edit screen displays, the "editable" are of the page is blank and I cannot type in that space.

Thinking that it might have been my laptop I was working off of, I have tried from a different machine and even browser just to be sure.

Also, cause I thought maybe the Ubuntu upgrade might have messed with some permissions on the tiki directory, I went ahead and repermissioned the tiki directory with:

sudo find /var/www/tiki -type d -exec chmod 777 {} \;

sudo find /var/www/tiki -type f -exec chmod 644 {} \;

Still no luck.

Anyone have any insight as to what might have happened?

Thanks!

Flash

posts: 1559

Hi Aaron,

I have similar problems on individual instances, but no problem with same versions of Tiki on same version of Linux (ex local: Ubuntu 14.04).

I have not yet a picture what's going on and most instances are working well. Cache maybe? No idea. Anyway, I am using TIki 12, 13, pre-14 all from SVN (like kind of rolling release).

As said: no idea yet, but looking into that.

I hope to not forget to mention to you once I found out the reason (and the solution) ... :-) ...

Regards,
Torsten


posts: 11 United States

Torsten,

Thanks for the reply. It's good to know that it is not just me. ;-)

I decided to rerun my Tiki Check. Everything looks good except for my PHP Security properties. I'm seeing lots of "Risky" items now, as well as "Unknown" for the upload_tmp_dir.

I think I'm going to try and dig into the TMP directory and see maybe that's my problem.

I also ran a security check:

Filename State
./temp/public/codemirror_modes.js This is not a Tiki file. Check if this file was uploaded and if it is dangerous.
./temp/public/codemirror_modes.css This is not a Tiki file. Check if this file was uploaded and if it is dangerous.
./db/tiki-secdb_12.0_mysql.sql This is a modified File. Cannot check version. Check if it is dangerous.
./db/local.php This is not a Tiki file. Check if this file was uploaded and if it is dangerous.

Let me know if you find anything Torsten.

Thanks!!!


posts: 11 United States
Still troubleshooting. Cleaned out the system cache through the UI and then manually just to be sure. After a restart of Apache, still no luck. cry

posts: 11 United States

Open to suggestions... should I try upgrading? (I'm on 12.0) However, didn't seem to help Torsten since he was on different versions of Tiki, but 14 of Ubuntu. I'm at a loss now...

~Flash


posts: 11 United States

Just realized that ALL new pages are acting the same as well. Crap.

I'm stumped.


posts: 98 Greece
Same here. Just upgraded to 13.1 from 12.2 and all new pages or edit existing pages take me to a big blank window, into which I can see / write nothing.

posts: 98 Greece
...while I can edit articles. I have not found any solution so far.

posts: 11 United States

So my problem is fixed! Yay!

 

I upgraded to 12.3 and that fixed my edit issues.

 

I did have one major issue while trying to upgrade to 12.3, after I had copied the files over to my server, during the upgrade process the installer hung and I wasn't able to complete the install. After that, the Tiki site was completely down and not responding. I had to edit my apache2.conf file and change AllowOverride All before I could get back into the site. Restarted the install process and everything went perfect after that.