Loading...
 
Architecture / Installation

Architecture / Installation


Adminusers.php does not allow me to add users or groups

posts: 4 Finland

Everything else is working fine without any problems whatsoever. When I try to add a user or group however, I get the following error message:


No data received

Unable to load the webpage because the server sent no data.
Reload this webpage
Press the reload button to resubmit the data needed to load the page.
Error code: ERR_EMPTY_RESPONSE

posts: 212

You did not tell us which version of Tiki you have installed. Are the user name and group name you tried to add the same? Does your server have mod_security installed? If mod_security is installed, do you have SecFilterScanPOST filter set to On? Can you add a user name made of random characters?

Tom


posts: 4 Finland

I apologize: I am using the latest stable version (12.2) of tiki, and the only user I have is the admin account. I cannot add any other users. I have tried tens of different usernames, random and not. The same for the group names. It is not the name itself that causes the problem.

I have tried separate installs of tiki. They all have the same problem. It is not PC specific, not browser specific, nor version specific (for example tiki 9.x had the same error).

I have contacted the host about the mod_security but have not been able to get a response yet. I am leaning towards it being a server issue, but where to look?

Thank you in advance.


posts: 4 Finland

This is the reply from the host...after I already mentioned I have tried installing other versions of the wiki. *sigh*


----------------
Hi there,

It appears this is causing a 'segmentation fault' in php, im guessing that tiki wiki does not like php version 5.4 which we use on free hosting.

Could you please try manually installing a different version of tiki wiki,

Please let us know if there is anything further we can do for you.


posts: 126658 United Kingdom

Coo, bad luck VaMi, i've only ever managed to cure segmentation faults by updating PHP - and quite a few of them i found when on PHP5.4 were coming out of the Zend library, which we have no real control over. 5.5 is far more stable generally.

Maybe they can co a minor update? Looks like 5.4.33 is the most recent 5.4 (you can see your PHP version in phpinfo, on the admin menu)

jonny


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.