Loading...
 
Architecture / Installation

Architecture / Installation


after a fresh 12.3 installation : no permission given to admin for tiki_p_admin_users

posts: 3

Dear all

Thank you very much for this great tool.

I have just tried to install tikiwiki 12.3 on my machine. Everything seemed to go smoothly during the installation process made via the wizzard.

Unfortunatelly, when I started to configure the installed wiki logged as admin user, I keep receiving the following error message when trying to perform crucial operation (managing users for example)

You do not have permission to use this feature: tiki_p_admin_users

Could anyone give me a clue on this?

Thanks in advance, Best regards

Sam

--
Samuel Kortas, PhD
Computational Scientist
KAUST Supercomputing Lab

posts: 3621 United States

Very odd... it appears that your admin user account has become corrupt for some reason.

You can easily fix this issue:

  1. Re-run the Tiki installer (tiki-install.php)
  2. On the Install/Upgrade page, select Upgrade.
  3. Then, after completing, on the Configure the General Settings page, at the bottom, complete the Upgrade Fix item.

HTH,

- Rick  |  My Tiki Blog |  My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.
posts: 3

Hi Rick

Thank you very much for your reply and hint.

I did perform an upgrade following thoroughly your instructions but I have still got the same error. I also try with tiki 9.9 and the symptom is the same

Rick, what could I check to have more clue? I know how to program in php but the code is really huge. What could I try?

thanks for any help and thanks again for your work.

Best

Sam

posts: 3621 United States

Did you clear all caches (Tiki caches and your browser) following the upgrade?

You can also turn on the Tiki error reporting... it may help.

 

posts: 3

Thank you very much Rick for your answers.

 

Clearing the tiki caches did not help. I tried a few things and finally found a workaround. I finally installed tiki-wiki as www-data - the user running the process apache. In that configuration, everything went smooth and fine.

 

To your mind, what could create a problem when I installed the wiki in public_html with files owned by a regular user? Were you aware anyhting that could cause a problem?

 

Best regards  and thanks again for your efficient and inspirating help.

 

Sam

posts: 1811 Catalan Countries

Hi Sam, and welcome to the Tiki Community!

Please, ensure that you run the script 'setup.sh' on a shell from the root folder of the tiki installation in your webserver. And choose the permission model that best suits your server setup (Debian server?).

See:

http://doc.tiki.org/Installation?structure=Tiki+Installation+Guide#Example_2:_installation_with_shell_access

and

http://doc.tiki.org/Installation?structure=Tiki+Installation+Guide#File_and_Folder_permissions

 

Nice to see people from supercomputing labs using Tiki! :-)

Cheers

Xavi

 


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.