Architecture / Installation

Architecture / Installation

InterTiki stop working after upgrade

posts: 2 Italy

I have two sites on the same server, on different directory and with different third level url.
They are configured to user Intertiki to centralize user accounts.
After upgrading both from 9.6 to 9.9 and then to 12.3, login on the slave no longer works.
I get this error:
XMLRPC Error: 2 - Invalid return payload: enable debugging to examine incoming payload

How can I find more help?

posts: 1561 Germany

Hello battarsa,

I am right at the moment working on the bug with Nelson since a few hours, which I recently discouvered. Sadly I haven't been aware about your post.

Nelso seems to have found the initial problem, worked out a work around and we hope it could be fixed in future.

The bug is quite strange and actually there are two bugs involved.

Please refer to here: https://dev.tiki.org/item5614

A second bugreport for the other related bug is under way.

In case we did not yet well comment, please come back to me. I'd be happy to help (if I can).

e-mail: torsten.tiki.org


posts: 1561 Germany

Hello battarsa,

two things you can do:

1.) edit the file "remote.php" in the tiki root:

13 include 'tiki-setup.php';
14 require_once('XML/Server.php');

uncomment or delete the scond line (will be soon deleted for newer Tiki 14+ releases)

13 include 'tiki-setup.php';
14 // require_once('XML/Server.php');

2.) in case you did change the Intertiki key and save in the Intertiki admin area, you might have unknowingly triggered a second bug:

Delete the key, save and setup the Intertiki configuration again.

The problem is, that the Intertiki key is aswell the value of that pereerence, as the Id of the preference and when you change the key, the Id is not changed - an error "wrong server-key" will be output. Deleting the key, saving and then setting up the key again will give a new Id and then it should work.

We consider both a bug, but the second one as an uncritical bug, which we aswell caot easily fix, cause the fix seems to be quite time consuming. It is kind of "non-perfect code" and we found this workaround. We hope, that one of us will remember once we have more capacity for this, but right now we have to focus on the Tiki14 release and a number of actions where we need to consolidate and "streamline" code in other parts of Tiki.

I hope t description helps.

If you cannot get around your problem, feel free to write me an e-mail or to contact me IM.




posts: 2 Italy

Hello Torsten Fabricius, I edited the file remote.php as you told and it worked. No need to delete the key.