Architecture / Installation

Architecture / Installation

Solved but not understood, yet...: Fatal errors when upgrading to 15.2

posts: 98 Greece

Let me describe briefly how a few problems arose while I tried to upgrade from 12.9 to 15.2.

During the initial tiki-installer section, at the point we connect the domain to the database, I got the following error: Fatal error: Uncaught exception 'TikiDb_Exception_DuplicateEntry' with message 'Duplicate entry found (...) Exception.php:13 Stack trace: #0 /var/www/vhosts/mydomain/mysubdomain/lib/core/TikiDb.php(164): TikiDb_Exception::classify('Duplicate entry...') #1 (...) mysubdomain/lib/core/TikiDb.php(72): TikiDb_Pdo->query('UPDATE `tiki_pa...', Array, -1, -1, 'exception') (...) Exception.php on line 13

Despite this, my wiki looked like it was working properly and I actually worked on it for a couple of days. Then, while playing around with the look&feel, I noticed another error message, saying: Database Version Problem Your database requires an update to match the current Tiki version. Please proceed to the installer. Using Tiki with an incorrect database version usually provokes errors. If you have shell (SSH) access, you can also use the following, on the command line, from the root of your Tiki installation: php console.php database:update.

Well, I didn't have secure shell access, so I asked the hosting company to run php console.php database:update which not only didn't take care of the error, but actually made me lose admin privileges. I had to go back to my 12.9 installation (through restore) to have my wiki operational again.

So my question is: What went wrong? What the above two messages indicate and how can I safely upgrade to 15.2? (well, three questions actually)

posts: 18


I just finished upgrading my Tiki from version 9.x to 15.2. I did not realize that I would have so many problems but to help others, I will list my workaround:

Blank pages on tiki install.

After searching in vain for a solution, I found that the issue was related to the PHP installation. Version 15.2 requires PHP 5.5 I have Centos 5 and PHP 5.5 is not available on yum. So the option was to load this from the Remi repository. BTW, PHP 5.5 does not use MySql but rather mysqli.

To Check create file TestMySql.php

posts: 18

I upgraded to 15.2 and am using the tikinewt theme
with the bootstrap option

(BTW, there is no "default" option in the admin when selecting the theme. I also do not know what these options: classic, bootstrap etc actually do. More on this in a different post)

Anyway, I have a TOC of my structure and am using "fancy". The reason is that I also display the page description .

The issue is that the description is italic. I want it to be normal.

Can someone please tell me how to accomplish this?
I have scoured the css files and have set all the italic to "normal" but it still displays it in italic.


posts: 98 Greece

I attempted once more to upgrade from 12 -> 15 with not success. This time from 12.11 -> to 15.4. I had hoped the newer versions would be more kind to me, but not.

So It is the same fatal error after I try to connect db to my wiki folder:
Fatal error: Uncaught exception 'TikiDb_Exception_DuplicateEntry' with message 'Duplicate entry found
and a few more lines like these in the first mesage above that conclude in
/lib/core/TikiDb/Exception.php on line 13

Just the day before I upgraded 12.9 -> 12.11 with no problem whatsover. So it looks like the problem has to do with the 12 -> 15 transit. I should solve it or I am stuck with 12...

How I do the upgrade each time, in case I am mistaken.
(a) I rename old folder
(b) unzip new version in a folder with my site's working name
(c) run the installer from there
(d) connect to my db

I don't do any export - import of db, I just reconnect the existing with the new folder.

Any hint?

posts: 98 Greece

It seems that I solved my problem while upgrading, but still I have not understood how such a problem could arise -and I mean the duplicate entries.

Let me explain why.

As I describe in the messages above, every time I was trying to upgrade I was receiving a duplicate entry error, which didn't let me connect to the database. The error was starting: Duplicate entry found (%CE%91%CE%BD%CE%B8%CE%BF%CE%BB%CE%BF%CE%B3%CE%AF%CE%B1+%CE%95%CF) etc. etc. A friend told me "why don't you look at http://www.url-encode-decode.com/ to see what these symbols are supposed to mean"? Well I checked and it was the first 10 or so letters of a few wiki pages of mine. Now, all these wiki pages are in Greek, but lets translate in english, so you will easily understand it, the pages would be "Science Fiction Bibliography (2014)", "Science Fiction Bibliography (2015)" and "Science Fiction Bibliography (2016)". Now, all these pages are different and of course they have different ID, so how on earth the database may be confused?? The easy solution was to change the titles to "111Science Fiction Bibliography (2014)", "222Science Fiction Bibliography (2015)" etc. etc. Then again the same error message with other wiki pages which started with the same Greek word, more page renaming and 10 pages later, I was able to upgrade with no error.

But: Is it really possible that Tiki or my Database may be confused by such a common thing, as wiki pages that start with the same Greek words but differ later in the title? Can't really happening... Right?

And how I will avoid it in my next upgrade? More file renaming?