Loading...
 
Features / Usability

Features / Usability


users and categories

posts: 7

Hi
I am using version 5. I added categories, enabled them and gave all relevent groups the right permissions; and yet when loged in as a user of that group I can not see the "category" tub when edditing a page.
I eraased all categories, cleared the cache, assigned global permissions againg and still - no gategories for the users.
Users can see category list but can not add category to page.
any ideas?

thanks
Shlomit

posts: 4

We're having the same exact problem. We even went as far as deleting tiki and the database and reinstalling it and we are still having the same problem. None of the permissions set are working with the features that we have enabled; calendar and categories.

I posted about this last week and haven't received any kind of response. Rather disheartening as this is the only wiki that we have found that will work well with our small community.


posts: 1572 Canada

Hi!

It's a feature, not a bug.

In the permission section, it says: "You might want to also set the tiki_p_modify_object_categories permission under the tiki section".

You need to tell Tiki which users are allowed to add and to remove to categories.

Best regards,

M ;-)

posts: 4
That permission was set under the tiki section. Still no go.
posts: 7

Hi Marc

Thanks for the tip. I did not get that message about tiki permissions.
It worked.

Shlomit

posts: 1

I have been working with Rangy Wulf on this. The problem doesn't appear to be adding things to categories. We can set up pages and add them to categories just fine. We set up accounts, set up groups, give only certain groups permission to see certain categories. We make sure that anonymous and registered users not a member of those groups have no permissions to the restricted categories.

All works perfectly.

...until one logs in as a registered user who is not a member of any other group, and can view all the restricted content regardless of what category it is in.

As the ability to restrict certain content to certain groups was the main feature we picked Tiki for, this is somewhat problematic.


posts: 289 United States

Something is wrong somewhere because I've setup a category that makes Wiki pages only available to some custom groups, but not the standard "Registered" group and it works just fine (Registered users not in one of the custom groups cannot see Wiki pages under that category).

Check category administration, make sure that the option to ignore category permissions is unchecked. As always, clear your Tiki caches. Are you absolutely sure that you're removing permissions from the Registered user group? Are your other user groups children of the Registered user group? That is to say, they inherit permissions from the Registered user group (I don't think this is necessary but it's how my user groups work).