Loading...
 
Features / Usability

Features / Usability


Chinese

posts: 6

I see that there are pages here with Chinese wiki names, however, if I try to create a chinese named wiki page using double brackets it doesn't seem to work. I have set the encoding of my site to UTF-8, and the chinese characters display correctly, it just doesn't recognize them as a link, even though they are in double brackets.

I wrote ??. As well as ??.

(Note, the source of the above two chinese lines was written with double brackets, although it doesn't show in the forum.

posts: 6
This page says that TikiWiki can't do this, but I know i've found pages here with Chinese titles, such as the page for the Traditional Chinese translation. So did they use some special work-around, or has the problem been fixed?

posts: 1001 Canada

Hi Luhmann,
This site must not allow non-anglophone characters in double brackets (Admin Wiki setting). However it's only one way to create a page, the one I prefer being the quick_edit module which you can get on this site. Enter the name there, and create the page.
wink

posts: 6

Thanks! I found the setting to enable non-English wiki names and now it works. The setting is called "complete" which is confusing, but now I know what it means!

That module looks helpful as well, I'll check it out!

posts: 6

Chinese seems to work throughout most of the site, but not everywhere. For instance, when displaying categories, chinese appears fine in the category list, but when a chinese word is selected as the current category then the Chinese encoding breaks and I just get gibberish.

Should I post this somewhere else?


posts: 6

Thanks! I found the setting to enable non-English wiki names and now it works. The setting is called "complete" which is confusing, but now I know what it means!

That module looks helpful as well, I'll check it out!

posts: 6

Chinese seems to work throughout most of the site, but not everywhere. For instance, when displaying categories, chinese appears fine in the category list, but when a chinese word is selected as the current category then the Chinese encoding breaks and I just get gibberish.

Should I post this somewhere else?


posts: 1001 Canada

If you have a bug you can send it to SourceForge according to ReportBug.
It will take time to get reviewed because our non-latin community is rather small, but it may be worth it.
Thanks for caring anyway.


Upcoming Events

1)  Thu 23 Jan 2020 14:00 GMT-0000
Roundtable Meeting 2020 01

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.