Loading...
 
Features / Usability

Features / Usability


Action Calendar to Module triggers Fatal Error

posts: 681

When I want to assign my "Action Calendar" I get a fatal error when I click on the tab "Module Options" any help is greatly appreciated in getting rid of this error. The following:
''__
Fatal error: Call to a member function assign() on null in /home/tpworg/public_html/modules/mod-func-action_calendar.php on line 39__''

The following is line 39 in my .php file:

$smarty->assign('show_calendar_module', 'n');

Thanks in advance for any help. I am using the latest Tiki 14.0

posts: 496

please check r55702, should fix this

or if you want to fix manually: in the php file switch line 39 with 41 (first initialize the smarty lib, than call the assign function)

cheers,

gezza

posts: 681

That worked gezza, thanks a million for the help! Appreciate it much! I made the fix manually, I am sorry but I did not understand r55702, so I want to thank you for including the switch manually option.

Thanks again!

posts: 1554

Hi jmorris,

r55702 refers to a recent or just committed release. It is the release number of the svn code base - example of a long version of a svn note of a Tiki 14 instance (German version):

Letztes Update von SVN (14.0beta): Montag April 27, 2015 15:00:32 CEST- REV 55242

So r55702 is an abbreviation for *... REV 55702

As you see, 55702 is a higher number than 55242, which means 55702 is younger and should contain fixes and enhancements.

If a developer tells you something like "please check r55702, should fix this ", that usually means, that the developer did check the fix he explained to you, committed it to the code base and you should svn-up your installation and check, if the problem is sorted.

This only works for you, if you run a rolling release via svn or you use a latest build download version, which would need a bit more time consuming update.

svn up is quite easy, but you need shell access to the server (some shared hoster have that aswell).

You just login to the shell, move to the tikiroot (_$ cd path), then backup the database (_$ mysql options parameters values) and the update (_$ svn up).

Usually after 2 minutes including login you should have updated the Tiki and thus test if the fix does the job.

Cheers,
Torsten

posts: 681

I apologize for the looong time late reply Torsten. Been away for awhile!

Thank you for the clarification and the heads up on etiquitte. It's greatly appreciated.


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.