Loading...
 
Features / Usability

Features / Usability


Tracker Pretty Templates Unusable all the sudden

posts: 681

I don't know what happened, but my trackers are not talking to the templates anymore, I've tried resaving template pages, clearing cache, and other various rookie attempts, and nothing is talking to eachother anymore. With tracker form I was able to create a tracker item and a corrosponding page as well, and now none of my trackers are working with pretty templates. I can create items, but I cannot create pages.

And the pages that were created before this transpired, have this php error message.

NOTICE (E_USER_NOTICE): Undefined property: Smarty_Tiki::$security
At line 763 in vendor_bundled/vendor/smarty/smarty/libs/Smarty.class.php
NOTICE (E_NOTICE): Undefined index: _33
At line 50 in vendor_bundled/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(171) : eval()'d code
NOTICE (E_NOTICE): Trying to get property of non-object
At line 50 in vendor_bundled/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(171) : eval()'d code
NOTICE (E_NOTICE): Undefined index: _28
At line 64 in vendor_bundled/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(171) : eval()'d code
NOTICE (E_NOTICE): Trying to get property of non-object
At line 64 in vendor_bundled/vendor/smarty/smarty/libs/sysplugins/smarty_internal_templatebase.php(171) : eval()'d code
NOTICE (E_NOTICE): Undefined index: sameas
At line 150 in lib/wiki-plugins/wikiplugin_footnote.php


If anyone has any feedback on this I would greatly appreciate it. Will it ever end?

posts: 4521 Japan

Hi John,

Was there a Tiki version update prior to this problem, or other change at the site that might be related? Also, you mention clearing the caches - did you rebuild the search index? Sorry, I don't have any better questions/suggestions at this point.

-- Gary

posts: 681

Thanks Gary,
No tiki version updates, I just rebuilt search index per your suggestion, no change. I am stumped, but thank you for your time and suggestions Gary.


posts: 681
I'm probably just going to dump my installation, re-install it all over again and copy the content in to the new install. I've done it before, I'm getting pretty good at it.

posts: 681

Bernard, thank you for your time.
I rebuilt index in the ACP. I use SSH for many things though. Can you please direct me to the proper SSH command to rebuild index? Thanks!


posts: 681

Bernard thanks so much again, I performed the SHH commands and they all executed successfully, my website runs faster now! Was that supposed to happen?

On to the main issue, nothing has changed, still same issue persist, thanks Bernard.


posts: 681
I may have, I also renamed a few template pages, but I renamed them back to their original name.

posts: 681

Looks like footnotes may be rearing its ugly head again.

When footnotes plugin is used, the syntax that populates the page is
{footnotearea }
instead of
{footnotearea}
, there is a space that is inserted between "a }". I closed the space up but there is still an issue. I disabled footnote plugin and my pages still don't work with trackers, but there seems to be something wrong with footnotes again.


Here is the latest PHP error report

NOTICE (E_USER_NOTICE): Undefined property: Smarty_Tiki::$security
At line 763 in vendor_bundled/vendor/smarty/smarty/libs/Smarty.class.php
NOTICE (E_NOTICE): Undefined index: sameas
At line 150 in lib/wiki-plugins/wikiplugin_footnote.php
NOTICE (E_NOTICE): Undefined index: sameas
At line 150 in lib/wiki-plugins/wikiplugin_footnote.php

posts: 2211
It is just a NOTICE about undefined index of the sameas param not affecting the functionality of the plugin.
posts: 681
Thanks Luci, still stumped then, I have no idea what is causing my current issues with trackers and pretty template.

posts: 681

Thank you Luci
I am unable to create a page by tracker item creation anymore. I can create a tracker item, but a cosponsoring page does not generate.

Also it appears the trackers are not talking to the pages anymore. So I have this template at https://thepatriotwoodwiki.org/notable+people+past.specimen

And I have this infobox template at https://thepatriotwoodwiki.org/notable+people+past.tpl

The .tpl should be called up into the .specimen, if you view the source of the .specimen you'll see at the top of the page, the .tpl is inserted.
This is problem number 1.

Problem number 2, when I create an item via trackers, a page is not created, the tracker item creates fine, but the corresponding page is not created.

This was all working well up until a few days ago, when I changed the title of the templates, I made the appropriate adjustments in the template to reflect the new titles, but it just broke. I renamed the templates back to what they were when everything was working fine, but to no avail.


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.