Loading...
 
Architecture / Installation

Architecture / Installation


Aw: Aw: Re: Composer not found problem

posts: 11
Uli wrote:
Any suggestions?


Grmpf. No suggestions after a month. :-/

I finally went the easy way and installed composer via apt (thanks god I have a dedicated server). But no success.
Then I found a hint somewhere in the Admin Settings to install composer via shell by using "./setup.sh composer". This didn't work as well - but for a simple reason: setup.sh was not set to be executable. I did that and the script was running... telling me "by the way" it should not be executed as root. What the #*!$&~§!
1. Great idea to provide this info AFTER the setup.sh is started without possibility to exit.
2. Only root has shell access on my server. How else should I execute it?
As expected now: No success, same result as before.

I uninstalled composer via apt again and rerun the script (of cause as root, as there is no other shell user), but no change. I still get "composer not found". Well - now in the Diagnose together with the message:

Composer errors

Composer returned some errors:

The Process class relies on proc_open, which is not available on your PHP installation.


trying apt install proc_open returns a message that such package can't be found.

What am I doing wrong?

Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.