Loading...
 
Architecture / Installation

Architecture / Installation


MySQL 5

posts: 3

I have installed TikiWiki and MySQL 5

The install script creates tables that have column names that are reserved words in MySQL 5 such as reads int(14) reads is a reserved word

I assume i should have used MySQL 4

There appears to be other errors when using the wiki, such are creating structures. I guess that this is a database version incompatibility too.

Advice gratefully received

posts: 2881 United Kingdom

MySQL 5 is not supported.

The latest you can use with TikiWiki currently is 4.1

Cheers

Damian

posts: 28

> MySQL 5 is not supported.
>
> The latest you can use with TikiWiki currently is 4.1
>
> Cheers
>
> Damian
>

Damn. Any plans to make Tikiwiki working with Mysql 5.0 ?

posts: 2881 United Kingdom

>
> Damn. Any plans to make Tikiwiki working with Mysql 5.0 ?

Once ADODB supports it and a developer running mysql 5 has the time Im sure it will happen.

Damian

posts: 1092


> Once ADODB supports it and a developer running mysql 5 has the time Im sure it will happen.
>
For the tiki-install problem explaied above, it is only some tikiwiki tuning in the script tiki.sql and the schema.

-sylvie


posts: 25 United States

Actually all I had to do was quote the reads reserved word and that cleared the error.

I have two production TW's running on MySQL 5.0 AND PHP5 with all of the main modules working fine.


Upcoming Events

No records to display

Menu