Architecture / Installation

Architecture / Installation

tiki-2.1-mysql.sql missing

posts: 838 United Kingdom

I posted a problem to the Features/Usability forum with upgrading from 2.0 to 2.1 with PHP Warnings and Notices but think perhaps it should be posted here.

A key question is whether the 2.1 installation packages should contain a file called tiki-2.1-mysql.sql in the db folder. The more serious PHP Warnings were because adminlib.php tries to open this file but cannot find it. ie

File: adminlib.php
Line: 403
Type: file(db/tiki-2.1-mysql.sql) function.file: failed to open stream: No such file or directory

This file is not in the .zip I used and doesn't seem to be in the .tar either ??

All the other PHP Notices are an "Undefined index" of one sort of another - so I'm wondering whether something else is missing.

Could this be an error I made or something wrong with the update package. I really need some input to point me in the right direction since I can go back and redo the upgrades (4 or 5 sites) but don't want to do this until I'm sure that I can fix it.



posts: 289 United States

Rick has confirmed that there were no changes to the database between 2.0 and 2.1 so perhaps your database has corrupted?

I upgraded recently from 2.0 to 2.1, by downloading the upgrade package (i.e. not the full install). All I did was to copy and replace the changed files from that upgrade over the top of my existing tiki installation. No database scripts, no installer initializations, and it worked fine, without any errors of any kind.

Maybe you could backup your database and try to go back to 2.0 and see if you still get errors. Then try the upgrade again if not.

posts: 838 United Kingdom

Sorry - but I still think there is something wrong here.

I have now regressed all the way back to the 2.0 install and I am still getting the PHP Notice errors.

To make doubly sure I made a completely new/fresh 2.0 install with no changes other than to switch on "Report all PHP errors" and "smarty notice reporting" plus I removed the assistent module to declutter the menus. This clean 2.0 install gives all the "Undefined index" errors - you can see this at http://www.tw2.enmoreservices.com/tikiwiki-2.0/ and login with admin/admintest to see the errors. I'll leave this test site open for a while so it is available for anyone to look at.

I then created a second clean 2.0 install which I upgraded to 2.1 by the simple "copy and replace" method - but this gives the same "Undefined index" errors plus when you clear the cache this triggers the missing tiki-2.1-mysql.sql error. You can see this 2.1 site at http://www.tw21.enmoreservices.com/tikiwiki-2.1/ and login with admin/admintest to see the errors. I'll also leave this test site open for a while so it is available for anyone to look at.

So I think there are bugs here - which whilst they don't seem to affect the running of my site are quite disconcerting.

Can anyone else repeat this?

Should I post this at the Bug list?

posts: 289 United States

Just for fun I turned on PHP error reporting on one of my sites (never used it before) and I didn't get any errors. Something doesn't seem right with the errors you're getting. I've pasted an example below. This question is aimed at everyone; What kind of filename is "enen^%%74^746^746E86FB%%tiki-show_page.tpl.php"? Is this normal? To me, it's as if something is corrupted somewhere. Or maybe something to do with PHP is not configured correctly on the host server? I bow to someone's else superior knowledge.

PHP Errors on eromneg's site


posts: 838 United Kingdom

These file names are normal for every tiki site. They are the compiled .tpl files that are used, and are to be found in the templates_c folder.

Looking at the original .tpl and the compiled .php suggests that something is wrong with the _tpl_vars array ie some of the values are not set. I think this data originates in the tiki_preferences table but I'm really not knowledgeable enough to understand what could be wrong. But I wouldn't have thought there's anything wrong with my php host settings - they run php 5.2.6 and all my non-tiki stuff is fine and my old 1.9.11 stuff is OK as well.