Loading...
 
Architecture / Installation

Architecture / Installation


Tikiwiki Stalling in Firefox

posts: 20

My tiki, ArkBaseball.Com, seems to stall when trying to load a page in Firefox. It also does not work well in Internet Explorer (but nothing works well in IE). Yet, it works fine in Chrome.

I've been told that it has stalled long enough to enact Firefox's "stop script" message.

I'm running 8.1.

Any ideas?

posts: 1550 Canada

I suggest you upgrade to 8.4

Also, please see: tiki-admin.php?page=performance for some options. Perhaps you could the minify option?


posts: 181
Actually I see this behaviour right on tiki.org, which sometimes (not very often) loads blank pages. If I hit reload, the page loads correctly. Here at work I have an IE 8 on XP, at home Firefox and Ubuntu.

posts: 289 United States

Hi. Been away from Tiki for a while.

Sounds like you have multiple issues going on. If you're getting stop script messages then that is a client side issue. I haven't used newer versions of Tiki in a while but I know that stuff was being Ajaxified. Maybe you could try turning that stuff off on your own website and see if that helps?

As far as blank pages loading, then I'm inclined to think that's a server side issue (assuming your Internet connection is reliable), in which case you want to check things like memory allocated to PHP and execution time-out length for PHP.

Edit: I meant to add that I've seen this kind of behavior with tiki.org too. I think it's because it's just a really busy site and gets absolutely hammered. At peak times I'm sure Tiki's host servers get a really good workout! ;)

I'm not an expert though, that's just my two cents.


posts: 20
That's actually quite encouraging. No specific page, I've just noticed it stall when trying to load pages. Perhaps it depends on the version of Firefox.
posts: 181
Actually I am having this on tiki.org! Today I saw it on IE 8/XP, and now I see it on Firefox/Ubuntu. Sometimes a page loads blank, reloading produces the correct page.