Architecture / Installation

Architecture / Installation

Help, jquery seems to have stopped loading

posts: 14 USA

I had edited a wiki page and everything was ok the last time I accessed the site but now I cannot click the login button (no dropdown) and other things are not working. If I manually login or look at the web console I see an error about the $ variable not being defined. It seems that what or where the jquery javascript gets loaded at in the templates is no longer working. I don't see any .js resources listed in my web debug as being loaded either, just .css. I check what settings I can think of and jquery is allowed. What can I be missing? This happens on all the pages. Tried clearing the cache also.

ReferenceError: Can't find variable: $
(anonymous function)tiki-admin.php:1753

$(document).ready(function () {
'container': 'body'

posts: 14 USA
Something must have updated or safari or java.  The dev.tiki.org does the same thing (can't click the login, no dropdown and the menus are different) but the tiki.org website works fine. Mine works on Chrome but not safari but it worked a few days ago. Don't know where to start looking.

posts: 496


Try to delete your browser cookies.

There is a cookie about whether javascript is on/off, there were some troubles with it



posts: 14 USA
That fixed it. Thanks. I spent all weekend trying different settings on the tiki setup trying to figure out what went wrong then I noticed it was doing the same thing on tiki.org and I started to focus on a bad Safari / javascript update but this was it.

Upcoming Events

No records to display