Loading...
 
Architecture / Installation

Architecture / Installation


Disappearing Logo - Column Mash

posts: 16 US

Howdy -

I'm reinstalling the tikiwiki setup for my website at:

http://www.esperanto-sd.org

As long as I'm logged in, the logo appears just fine* and the right column stays to the right-most part of the page. When I log out (i.e., when I'm anonymous), the site logo and the right column initially appear/load, but once the page is done, the logo disappears and the right-hand column "collapses" into the middle column. The login widget, which I think it still there, is now hidden underneath the breadcrumbs bar.

It doesn't matter whether I have set the theme (Utopias) to fixed width or not. It also happens if I change the theme (for example, to "thenews").

I've gone in and changed the permissions to the logo - setting permissions to "Anonymous", for example, or just leaving the permissions unassigned. It makes no difference. So I suspect it's not a permissions issue. I think something's going on with the template.

(Browserwise, I'm on a Mac, using Safari. I don't have any other browsers yet, so I'm not sure if this behavior is happening across browser types.)

  • by "just fine", I mean it's visible. When I hover over the "Home" element of the menu, the entire logo is obscured by a grey box. But I 'd rather work on one problem at a time.


Has anyone else run into this? Any suggestions? Thanks in advance!

— Kat

posts: 3604 United States

If you can see it as admin but not as Anonymous, it is most likely a permissions issue.

Other things to check:

  • The module's visibility settings
  • The permissions for the Anonymous group
  • The permissions for the file gallery (if that's where you're storing the image)


Without being able to access your site, it is hard to see exactly what is going on. I was unable to duplicate your issue on the Tiki demo site — the Tiki logo appears fine using the Utopias theme.

HTH,

- Rick | My Tiki Blog | My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.
posts: 16 US

Hi, Rick,

Thanks for your reply! I don't think it's a permissions issue, now that I've had a chance to poke at it some more: when I access the page and am not logged in, I briefly see the logo in its proper place, as well as the login module too. Then, as the page finishes loading, the logo disappears (but the column is not affected). The right-hand column is briefly displayed to the right of the middle column, which is as it should be; however, because the right-hand column collapses into the center column, the login module is obscured under the breadcrumbs.

I tested this out by moving the login module to the bottom of the right-hand column stack o' stuff. Sure enough, I can now see the login module once I've logged off: once the page is finished loading, the right-hand column collapses into the center column, but the login module is overlaid on the center column text along with the calendar.

So now that I've done a little more messing around, I don't think that the issue is with permissions. I think perhaps that something in a master template might be broken. I haven't messed with any .tpl files; I've only messed with .css files and then only to change colors.

I think that this is an issue with this installation, in particular (and not with the browser), because I have the same version of tikiwiki running for another Esperanto group and it does not behave this way (with the same browser).

Thanks again!

— Kat


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.