Loading...
 
Features / Usability

Features / Usability


Trying to get PDF creation to work

posts: 838 United Kingdom

Hello - I've been trying to get the PDF Creation facility to work for me and am getting some strange results. With a very simple wiki Structure where the pages just have basic text it works fine. But for a Structure where I have used a template to put an image at the top of every page I get a series of errors as follows once I click the 'create' button from the Create PDF screen. (I've edited out the full path details in the text below - replacing it with the full path etc etc)

Warning: fopen() function.fopen: URL file-access is disabled in the server configuration in /home/the full path etc etc /tikiwiki/lib/pdflib/pdflib.php on line 384

Warning: fopen(http://www.development.enmoreservices.com/tikiwiki/img/wiki_up/Enmore_ppt_header.jpg) function.fopen: failed to open stream: no suitable wrapper could be found in /home/the full path etc etc/tikiwiki/lib/pdflib/pdflib.php on line 384

Notice: Uninitialized string offset: 2 in /home/.the full path etc etc/tikiwiki/lib/pdflib/class.pdf.php on line 2088

Notice: Uninitialized string offset: 2 in /home/the full path etc etc/tikiwiki/lib/pdflib/class.pdf.php on line 2088

This sequence then repeats several times (presumably for every page)

Line 384 in pdflib.php is in a function dealing with images and the line before is a comment "//hope GD is installed properly and the image is a jpg!"

As far as I know GD is installed properly since all the Image Gallery function work fine - and by chance the image is actually a .jpg.

Does anyone know what may be happening here? I've not had this error before so I'm not sure what the URL file-access is referring to?