Loading...
 
Architecture / Installation

Architecture / Installation


"Register as a new user" does not excecute - config error? or bug in v.1.9.8.3 ?

posts: 19 Germany

"Register as a new user" does not excecute - input wiped out
============
(a similar shorter text was also placed in error somewhere else in this forum)

Now upload 2007-12-09 from sourceforge.net - latest stable version -
. tikiwiki-1.9.8.3.zip - probably of October 26, 2007

INSTALL : Uploaded to terra-unika.com/
. (hoster westhost.com VPS, good techn.quality, includes SSH)
. Uncompacted on the server within SSH, top level DIR moved=renamed to terra-unika.com/tik/
. permissions probably all o.k,,
. later most features successfully activated as "admin",
. various functionalities tested, apparently so gar most or all is o.k.

CONFIG: User registrateion: was configured as good as possible (some features not
. explained in detail in the doc's, but probably this is not the problem origin)
. REM: Some config.input fields should have been filled automatically during
. installation, but were NOT, ---- like HTTP server and "prefix".)

PROBLEM-1 : Registration of new user does not work.
. From the start page as well as from the "admin" section
.... exactly same reaction - as follows:
, After input (good or wrong) and clicking "register": the page is apparently not refreshed.
.... The input fields are wiped out into blank state. - No mail sent to applicant.
.... No error message.
.... Test it: http://terra-unika.com/tik
, Then (after first tests...) I activated all files .htaccess by execution of the supplied .sh sript.
.... This did not result in any change of behavior for "Register as a new user".

PROBLEM-2 : There are perhaps similar problems when adding user groups.
.... But as I am new to TIKIWIKI, I can not know how it SHOULD be...

SERVER CONFIGS: (running with recent PHP v. 5.x --- MySQL 5.x )
. register-globals are on the server as default SET OFF,
.... are set to ON within main terra-unika.com/.htaccess
. There also PHP error log set to ON, and error messages sent to a log file.
.... No PHP error was registered in this log file for attempts in TIKIWIKI for the tests of "Register as a new user"
. The above PHP config. settings where then also added into the TIKIWIKI main .htaccess (ONLY in this one).
.... No change to observe for the problems, and no PHP errors found in the error log file.

DATE OF VERSION and very recent modifications on sourceforge.net ... ?
. Used version was: tikiwiki-1.9.8.3.zip - probably created Oct.26, 2007
. Apparently meantime known bugs have been repaired, related to register as a new user
. I conclude this from some other postings - late Nov. / early Dec. 2007
. But there is not specified which exact files were modified. So I am unable to settle this rapidly
. In addition, it apparently did NOT concern the precise problem communicated here.

Any helpful idea what I should do next?
. Is there some primitive personal admin or install error involved?
. Or is it a real software problem?

I could install it with an other hoster (shared hosting, other very good hoster).
Or I could wait for the next stable version and reinstall - it would include
, the meantime rectifications of problems with this code segment.
. But the communicated meantime rectifications (CVS version)
. did NOT concern the precise problem like described here above.

posts: 19 Germany

> Subject: "Register as a new user" does not excecute - input wiped out

I made an new install in http://terra-uunika.com/twk/
---------------------
this time with "default install.profile"
- and then intentionally without any configuration the following test:

Test: I entered the admin menu and tried to add a new user.
The behavior was liked described above: input fields wiped out,
no error messages, no user added, no other irregular behavior.

So the problem is a bit more defined: (v.1.9.8.3)
.......................................................
- either a primitive personal error of a lacking configuration option
- or a server-specific configuration problem
- or perhaps a bug in the current stable version tikiwiki-1.9.8.3.zip
- or?

Thanks for helpful comments or opinions!
.........................................

posts: 19 Germany

SERVER SETTINGS for PHP are:

  • cmd = disabled
  • passthru =disabled
  • popen = activated
  • proc_open =disabled
  • shell_exec =disabled
  • system =disabled

I am authroized to enable these on the server (I am user: root).

GROUPs EDITING:

  • Implemented = displayed for admin's config: "Admins" "Anonymous" "Editors" "Registered"
  • For ALL these: click on editing only results in redisplay of the middle page part.
  • "Add new group" : does nothing, only same re-display
  • The possibe key for problem understanding is perhaps: - The red symbol for "delete" is only displayed for ONE group fromt he 4, only 4: "Editors"


SET-UP / NOT DONE:

  • I did NOT execute : domain.com/tik/setup.sh (also not its newer version domain.com/tik/fixperms.sh )
  • because: instruction (is only in setup.sh ) is not fully explained for argument to supply.
  • +because: directory permissions are in fact already set like required, see doc.tikiwiki.org for this


The installed version does not behave like the group editing as described in doc.tikiwiki.org .
This is difficult to explain; because all configuration followed the detailed step-by-step-instruction there.

So it looks at the first glance like a software bug, but is perhaps just a lacking information in the install instruction - or a primitive install error.


posts: 19 Germany

I meantime installed Tikiwiki on the server of some other hoster, shared hosting.
From Fantastico. It is the basic verion of TikiWiki, hence user registration
not yet offered on the startpage.

In the admin ares of Tikiwiki, I tried as first action to add a new uswer.
If Fantastico in fact did all initil configuration, then this should work.
User registration did not work, exactly same problem like already described.

Now it tends to look like a bug... There are several recent posts related to this code segment of TIKIWIKI. Apparently, there is at least some problem. This is possibly related to recent versions of PHP and/or MySQL.

This part of the forums has apparently not enought visitors to advance with this problem analysis. So I will try to post a link to this in other locations.


posts: 1550 Canada

Hi!

Sorry you are having trouble. Thank you for the detailed report.

Let's rule out it's a settings issue.

How about if you install with "Default installation profile"
and just activate "Users can register:" in tiki-admin.php?page=login

Maybe you could also try the same thing with Tiki 1.9.7 (http://sourceforge.net/project/showfiles.php?group_id=64258&package_id=112134) and Tiki 1.10 (http://dev.tikiwiki.org/download)

Best regards,

M ;-)

posts: 19 Germany

Thanks for having found the time to deal with this! Here is what I tried just now:




Test 11: Hoster westhost.com = VPS - minimal pre-setup = in terra-unika.com/twk
--------------------------------------
PHP 5.26 or so - activated very recently. - does up to 20 MB - - - MySQL I think: 5.x
. Here I had already tested with "Default installation profile". So far nothing configured. - I went now with the TIKIWIKI menu to:
. http://www.terra-unika.com/twk/tiki-admin.php?page=login
. and ONLY activated: "Users can register:" (no other configuration done). Logout/Login and control: Yes, IS activated.

I logged out (Firefox). Went to Konqueror (perhaps other cookies... but is same PC / Linux FC = Red Hat).
. - called: http://www.terra-unika.com/twk

then registering as a new user : NAME: pjotre _. PASSW.: Don4Pedro _. EMAIL: ok at sit7.com _.
. (terra-unika.com is at westhost.com, sit7.com ist at websitesources.com)

Same unfriendly result : Input fields wiped out, nothing happened.
. Tried the same, but with generation of Password: ("NuJovoJA"). Same unfriendly result.
. Tried the same, but with differing pass words: Identical result, hence not the expected error message.


Test 12: Hoster totalchoice.com = shared hosting - Fantastico = in ladenx.com/tik
--------------------------------------
Newest PHP 5.x activated early Nov - the hoster had to settle a bit of trouble for FANTASTICO, e.g. for OSCOMMERCE.
(My variant of OSCOMMERCE in ladenx.com/ccr - is NOT via FANTASTICO)
. FANTASTICO there already has newest TIKIWIKI 1.9.8.3 . Installed it with: "Default installation profile" in: http://ladenx.com/tik

I went here also to: http://www.terra-unika.com/twk/tiki-admin.php?page=login
. and ONLY activated: "Users can register:" (no other configuration done).

Logout ftom admin : Yes, from now users CAN register. - Continuing on FIREFOX, I then registered on http://ladenx.com/tik as a new user:
. NAME: pjotre _. PASSW: Don4Pedro _. EMAIL: ok at sit7.com _.
. Same unfriendly result - input fields wiped out.


Passwords:
------------------------
Should not be in a public forum. I will try to send them directly to everybody adding comments here. - I do not ask for support for freeware. - But if developers would like to look inside the configuration details, I will enable this.


Further tests: Planned to do, perhaps Friday or so: implement version 1.10. (and if no succes, then also 1.7).
-------------------------------------------
Then I will add the test results here. - The program segments concerned had meantime some modifications, so it is of interest if 1.10. will work.

Why the efforts to get it running? - Tikiwiki is in my opinion by far the best philosophy. Here I have all in one - only need to learn to manage this illimited power. - And program code inside covers with my preferences - logical perfection close to mathematics - extremely rare quality. There is a lot for me to learn from during permanent future use.

posts: 1550 Canada

> Why the efforts to get it running? - Tikiwiki is in my opinion by far the best philosophy. Here I have all in one - only need to learn to manage this illimited power. - And program code inside covers with my preferences - logical perfection close to mathematics - extremely rare quality. There is a lot for me to learn from during permanent future use.

Hi!

I am glad you are are persevering.

There was some work done on tiki-register.php since 1.9.8.3

Can you get pre-release of 1.9.9?
http://de.tikiwiki.org/tar/lastiki_BRANCH-1-9.zip wait, it's not updated as it should

Best regards,

M ;-)

posts: 19 Germany

> > Test 12: Hoster totalchoice.com = shared hosting - Fantastico = in ladenx.com/tik
> > ---------------------------
> I was able to register and login to http://www.ladenx.com/tik/tiki-index.php with Firefox 2 on Windows XP.
> Please see screenshot, M ;-)

It is NOW working for me, too. From Firefox for http://www.ladenx.com/tik/tiki-index.php
- Did NOT work 3 hours ago...

First, where can I vote in favor of your right for a later luxury home within Paradise? :-)

Second, I tried to figue out how you reconfigured to make it run, and did not find reconfiguration in the admin config menus where expected. Which / where is my silly configuration error?

I could of course continue running TIKIWIKI on the initial test installation http://ladenx.com/tik
Anyway, will keep it active for reserve + comparison.

But so far it was intended to place TIKIWIKI on http://aaa.terra-unika.com/tik/
and this does not yet work, I just tested it again.
If a one-time-use via WIN-XP might unfreeze the problem, then I could of course settle it myself that way. But I already tried these days some alternate access (from Nokia 9500 Communicator via WLAN), and had the same problem. So I think it is a silly configuration detail which I did wrong?

Once that all is settled, I will do my best to add corresponding information on the doc's. So others and TIKIWIKI will benefit from this experience.


posts: 19 Germany

State of tests.

There are 3 new TIKI sites, und user registration works only for 1:

http://terra-unika.com/tik - ...not...
http://terra-unika.com/twk - ...not...
http://ladenx.com/tik - only here it works, but only because...


Config. settings have been compared 1 by 1
- no difference to state among the 2 versions .../tik/
Permissions (dir's, files) have been checked as far as considered significant. No signif. difference found.

Tiki logs checked
for ladenx.com/tik where user registration is working now.
The ONLY action to state which resolved the problem:
The first successful user registration was done frome a different PC, and Win XP (not from LINUX Red Hat like used here). - Browser identical, even same browser version.
ONLY AFTERWARDS, additional own user registration worked suddenly and properly.

Now testing is on the way to find the exact problem origin of this strange result.

First test showed: Cookies are probably NOT the reason.

Next test coming now: Other Win XP users will be asked to try to register on the sites where user registration still does not yet work. (This should not be the same PC from which ladenx.com/tik had been ,,unfrozen''.)

Results will be added here. - Opinions and recommendations can be added here. Hopeful to be close to the end of the story... Thanks to marcialaporte :-) who enabled these next steps of troubleshooting!

posts: 19 Germany

After the current tests, the most probable conclusion is:

The very improbably "unfreeze" of the problem by 1 use from Windows XP - this was apparently not the case.

Tikiwiki 1.9.8.3 probably can have the observed problems for a specific configuration of the server, and typically for newest PHP of late 2007. - I am not sure, but I suppose....

The observed case where it suddenly worked, was perhaps due to a meantime re-configuration of the server, and there is (now) in fact some specific ("unsafe") feature of PHP activated on that server (not on the other server). I know that this hoster was involved in trouble-shooting for the Fantastico packages, staff members working on it these weeks and days.

So the next test is to implement TIKI 1.9.9. and/or 1.10. (where this code segment got some modification) Then it will be discussed on the hosters forums (staff-supported) if/how Tikiwiki could be backed + pre-installed from now, to make sure for me that server configuration will in the future always be kept Tikiwiki-aware.

The more I tested + studied the inner working, the more I discovered the top qualities of Tikiwiki. The current minor problem - analyzed by these messages - will surely be mastered. - After success, I will latr try to contribute also a bit. The only most-used functionality which I did not find so far for/on Tiki, is a shopping cart on top of it. I did not yet really search for it... And if not yet done, I am sure, it will come earlier or later...

Comments, help, inspirations are welcome. - The final conclusions will be added here when the job is dcne.

posts: 28 United States

Sorry for joining this late. The symptom of "registration is submitted but page refresh is blank, no notification is made, etc" is fixed in the CVS tree for 1.9.8.3. The problem was a global was missing and there wasn't a check in place.

Having said that, I am having issues with Registration myself, that are unrelated to that specific problem, but it isn't working. I am running the latest 1.9.8.3 cvs. If I get it fixed, I'll let you know.

But the original problem stated, as far as I understood it, is fixed in the CVS tree for 1.9.8.3. If you are using the release package, you will have the problem.

Mike.




> After the current tests, the most probable conclusion is:
>
> The very improbably "unfreeze" of the problem by 1 use from Windows XP - this was apparently not the case.
>
> Tikiwiki 1.9.8.3 probably can have the observed problems for a specific configuration of the server, and typically for newest PHP of late 2007. - I am not sure, but I suppose....
>
> The observed case where it suddenly worked, was perhaps due to a meantime re-configuration of the server, and there is (now) in fact some specific ("unsafe") feature of PHP activated on that server (not on the other server). I know that this hoster was involved in trouble-shooting for the Fantastico packages, staff members working on it these weeks and days.
>
> So the next test is to implement TIKI 1.9.9. and/or 1.10. (where this code segment got some modification) Then it will be discussed on the hosters forums (staff-supported) if/how Tikiwiki could be backed + pre-installed from now, to make sure for me that server configuration will in the future always be kept Tikiwiki-aware.
>
> The more I tested + studied the inner working, the more I discovered the top qualities of Tikiwiki. The current minor problem - analyzed by these messages - will surely be mastered. - After success, I will latr try to contribute also a bit. The only most-used functionality which I did not find so far for/on Tiki, is a shopping cart on top of it. I did not yet really search for it... And if not yet done, I am sure, it will come earlier or later...
>
> Comments, help, inspirations are welcome. - The final conclusions will be added here when the job is dcne.

posts: 19 Germany

> Sorry for joining this late. The symptom of "registration is submitted but page refresh is blank, no notification is made, etc" is fixed in the CVS tree for 1.9.8.3. The problem was a global was missing and there wasn't a check in place.

Many thanks, Mike, for this key information.

My own case is resolved on a minimal level:
--------------
ONE of my 3 TIKIWIKI installs is working. I am already filling it with the initial content, for which planning and brainstorming is the major work time consumer (input edited + stored on a file on my local PC).
Later, when the next "stable" TikiWiki Version will go into distribution, I have all options (updating, moving to some other hoster, or so.) - I will avoid if possible the CVS version use because then the state is less standard - might be a handicap for future update packages.

For others who can choose the same temporary strategy:
--------------------
My first TIKIWIKI is working well on http://totalchoicehosting.com , from FANTASTICO, automatic installation. They offer a blog hosting tariff - approx. 40 USD/year - for TRUE FULL-FUNCTION hosting and top reliability. There are some setbacks (as far as I remember, 'only one main application per account' etc.), so please read details there before your hosting lifetime marriage with them.

A different solution to the underlying configuraiion problems:
--------------------
Now that one problem aspect is fully clarified, this aspect can possibly also and instead be settled by reconfiguring PHP behavior from within the .htaccess files (or by a specific additional php.ini for the specific directory tree of for all directories concerned). I already applied this, but so far only for the main directory /tik/.htaccess and without ordering extension to the others dir's (and without modifying the .htaccess files in the sub-dirs). - Hopeful to find the time to test to apply it to the sub-dir's, too.

Configuration problems if the hoster has secured PHP very much:
----------------
(like the also excellent hoster lunarpages.com), then this becomes a bit more complex, but the task is basically the same. (lunarpages.com offers FANTASTICO, too, but in the FANTASTICO offer there, Tikiwiki is lacking - perhaps for this reason.)

I hope that this current own state of experience may be helpful for others, too, and that other experience will be added here, when available... :-)
Pjotre.


posts: 19 Germany

The current state: ''still unresolved".
The problem is - in general - still unresolved, hence the impossibilty of user registrations (start page as well as within the admin menus).

My own problem is half-way setled - therefore not any more urgent for me.
As I have now one working Tikiwiki. So this is not any more urgent for me. The following information is mainly to supply information for TikiWiki developers, and to ask to add helpful information here.

Tests on latest newest versions: They still include the same problem:
* v.1.9.9. : New TikiWiki 1.9.9. was installed on a server of westhost.com . Same problem for "register as a new user".
* v.1.10. : Current TikiWiki 1.10. (sourceforge.com / 25 Dec. 2007) installed on same server. Same problem.
* v.1.9.8.3. (FANTASTICO / installed Dec.2007) on server of totalchoicehosting.com : First same problem, 2 days later suddenly worked.
* v.1.9.8.3. (download Nov.2007) on server of lunarpages.com : Not yet fully installed (requires time-consuming config. of work-arounds for their PHP securtiy settings)

Comparison with other "CMS-etc." systems.
* MediaWiki, vers. 2007-11, running instantly well on server westhost.com . Also on lunarpages.com, but required 2 days learning time how to configure. - No problems with user registration.
* Joomla + Xoops : Only temporary "test+view" installation 2007-11 on westhost.com : For both no problem with user registration.
* Typo3 : installation 2007-11 on westhost.com : working well: But feature of user registr. not yet activated.

Opinion about the problem reason: Configuration / PHP ?
Based on the behavior, I would guess that it is a problam with PHP ("global variables"). Lack of error messages means that it is probably not a problem related to permissions.
In the case of a "globals" problem, it would in the current software state probably be a configuration problem (I will try to settle this soon).
But it would also be a software issue. Apparently, the variables of user input are not detected, when entering again the registration program for the next step. Apparently, the user registration program therefore always falls back into its initial state "input prompts" instead of climbing up to the state "input evaluation".
So my current guess - but without having studied the program code.

Bug submission : declared as (probably) resolved:
I have moved my bug submission for the bug "user registration" to resolved. It is probably not a bug in the strict sense, because probably to settle by configuration, too.

Problem: file setup.sh
The install instructions in the documentation on tikiwiki.org and in the file INSTALL were apparently reviewed and are coherent - very helpful.
Only the file /tikiwiki/setup.sh does not explain in an easy-to-follow manner its various options and its working.
- what it really does (probably not much...)
- how to do the same by hand (SSH, FTP)
- how far these settings are vital or not.
But as far as I can understand, the problem with the user registration is not due to my non-execution of this tile.

Developers who want to use my installations for tests, can get the password for user "admin".
If wanted, please send a message to me from within this forum. - Apparently, everything else is working properly (other user input, wikis, articles, image uploads, ...). So it is just one feature to check.

Verson 1.10: Other information of interest - (does not fit to THIS thread, I know... :-) )
v.1.10. The language option in "user preferences" is apparently not preset to the current language, therefore drops to the first in the list (=Arabic).
In addition, after clicking "user preferences", the program apparently falls first into a layout state "text only" (no borders for HTML TABLEs).

Other helpful information related to the "user registration" problem would be appreciated.
The more I work with TikiWiki, the more I love its outstanding quality + concept. The current minor problem will be resolved very soon.


posts: 19 Germany
The problem "user registration" is probably settled

For one of the hosters I terminated trouble shooting with success. Like expected, the files .htaccess and php.ini required to be fine-tuned. (For shared hosting, hence the second php.ini within the customer director tree.) - Permissions required also to be changed for some hosters.

The mentioned files are now looking a bit complicated... PHP configuration problems.... When optimisation is terminated, I will try to add experience and sample files to the help documentation of TikiWiki.

My future contributions:

Now selected for permanent use : Tikiwiki Typo3 - both in quality far above average, both complementary. - I hope to be able to supply in a while my thanks for Tikiwiki by own contributions. Planned to develop soon: PayPal feature, extended "friends" features, attractive skin elements, multi-language concepts.


posts: 19 Germany
all problems with user registration are apparently resolved by the hosting companies

The same TikiWiki Installationss which did not work until late Dec. 2007, are working well now when testing them again. The most probable explanation for this is that these hosters (and probably many others) meantime refined the configuration of new PHP versions 5.x.

Probably it concerned something which I settled with success for ONE of the hosters by own added file versions for php.ini and .htaccess (concerned PHP globals, session variables, cookies, deny/allow and so on).

the good sudden change was now stated for installed: 1.9.8.3. and 1.9.9. and 1.10.

this means that automatic installation of all these versions will typically now work properly for everybody.

Fantastico ... Other difficulties for beginners with pre-installed versions

The forums here show various beginner problems how to configure the various admin menus. In my opinion, beginners should clearly be told to do a first installation with the extended menu item list, not with the reduced minimal menu items. FANATASTICO installs with the minimal menu item list. Beginners will then have difficulties to activate the unknown features - and will possibly decide to use other CMS systems which are far below the top-of-top value of Tikiwiki.

I would, after comparison, never recommend a beginner to go the easy way by installing with Fantastico, as long as Fantastico preconfigures TikiWiki with an initial only minimal feature state.

version 1.10. of TikiWiki / bug informatin

... Arabic... Rectification of a former post in this thread: v.1.10. sets in the user preferences the language PROPERLY - does not drop to language 1 = Arabic.

But another observed mentioned bug was that, setting user preferences, made the display after confirmation drop into a wrong state (ONLY the next display). This could be repeated (CVS appox. Dec. 25, 2007). It is such an apparent bug that I do not place this in the bug register - is very evident and perhaps settled since a long time.

I continue to be impressed by Tikiwiki qualities - software coding level and features

As soon as I am not any more an unexperienced new user of it, I will try to add own contributions.biggrin