Loading...
 
Features / Usability

Features / Usability


seach for word "DNS" fails RESOLVED - thank you

posts: 43 Canada

Hello

I have about 6 documents stored in my wiki that have the word DNS in them a couple of times. They also have the words secondary, primary, slave etc.. Those are all searchable. But the word DNS can't be found through a search. Is that a reserved key word or something?

I'm running tikiwiki 4.2

Sanity check anyone?

posts: 289 United States
Are you using the MySQL Full-text search? (as defined in the admin search options)
posts: 43 Canada

Hi Darkbee

I guess I'm not using the full-text search option... Can't seem to find it to confirm though. In the admin search option I don't see anything about a full-text search option. I'm in the Admin -> Search page. Am I missing something?

Thanks

posts: 289 United States

Sorry, I might have mislead you slightly, I'm not using 4.2 myself, so I don't know for sure exactly what the options are but historically Tiki has had two methods of searching:

  1. MySQL search using the features of the database
  2. Tiki-built search


1 is better, and if that is what you're using then you shouldn't have any problems searching for "DNS". I even tried it in one of my Tiki's (5.2) and was able to successfully search for that term on a page I'd updated only moments earlier.

However, if you're using 2 then this requires an index to be created periodically to allow searching, and if you try to search for terms on pages that haven't been re-indexed recently then some search terms will not yield results. Normally the indexing is done automatically but it might not be done adequately frequently in some case in which case there are options to refresh the search indexes yourself (you should see those somewhere on the search admin page).

Just to be clear, we're talking about this page:
tiki-admin.php?page=search

The very first option in 3.x is "Database Search" which is number 1 of what I'm talking about. Number 2 is underneath it and curiously checked permanently apparently in 3.x. A little further down you should see links about refreshing the indexes. You could try them, but before you do perhaps try clearing your tiki caches on tiki-admin_system.php.

posts: 43 Canada

Well, on mine, both are selected. Both database search and tiki-search. How's that for confusing. I never touched any of this during the setup. The wiki article name is DNS for gods sake.

The kicker is I can search for other strings in the same wiki document that contains the word dns and it works fine.

I tried disabling the tiki-search and use strictly db search. No go.

posts: 289 United States

If memory serves, it's possible that just because you have full-text enabled, doesn't mean Tiki is using it. It should in theory just work, but there could be an odd configuration of your MySQL database which prevents it from being used.

In addition, If I also recall correctly, different search modules invoke different search methods, did you try the refreshing of the indexes like I suggested, and also the clearing of the Tiki caches?

posts: 43 Canada
yes I did refresh the indexes. But as I said, I can find other words in the same wiki articles that contain the dns string. So that article is indexed.
posts: 289 United States

What actually happens? You get a search results page that says no results found? I'm kind of at a loss at this point. Sorry.

Just for kicks I created a page called "DNS" on my 3.x Wiki and put in a sentence or two on the page (threw in the "DNS" term in there again for good measure). The search found it without any problems, so it's definitely not some kind of "reserved word".

Have you tried searching directly from the search page: tiki-searchindex.php? (I don't know how you're currently initiating the search).

posts: 43 Canada

Very interesting.

I used the tiki-searchresults.php option from the side bar, that looks like the same script as the main search option, anyhow, it worked. It found dns and war file.

I'm not a religious guy, but as god is my witness, I haven't changed anything knowingly. From any search menu I can now find a wiki doc with the word dns or war file. Only thing that I did was disable and re-enable db searches. But that was over an hour ago.

posts: 289 United States

Ummm, the Lord works in mysterious ways? (as does Tiki sometimes) confused

I guess you can mark this topic as resolved? cool

posts: 43 Canada

Thanks for you help.

Tikiwiki is a dynamite piece of work. And all the forum posters & responders are a huge help.

Thanks for helping.

posts: 289 United States

No problem, not really sure that I helped but okay. biggrin

As for Tiki, for some reason I'm unhealthily obsessed with it and want to make every website I ever create use it. I just love it! cool

I'd use it for my own personal website but I don't have a spare MySQL database cry

posts: 43 Canada

I stand corrected, I see something that says:

This search uses the MySQL Full-Text feature. The indexation is always updated. and there's a Tiki search check box, which is selected. So I guess I do have the full text search enabled.

For fun, I changed the minimum search length to 2. But still can't find the word dns, but can find all sorts of other 3 letter words.


posts: 43 Canada
For the record, the word war isn't findable either. WAR as in WAR file. Makes it dam hard to document stuff when you can't find it. Probably other words I can't find either, if I looked hard enough.