Loading...
 
Architecture / Installation

Architecture / Installation


Invalid Database Error Message on 12.4 to 12.6 upgrade

posts: 41

I have upgraded my TikiWiki CMS from V12.4 to V12.6 using Softaculous.
The TikiWiki CMS now reports the following.

errors
Database Version Problem
Your database requires an update to match the current Tiki version. Please proceed to the installer. Using Tiki with an incorrect database version usually provokes errors. If you have shell (SSH) access, you can also use the following, on the command line, from the root of your Tiki installation: php console.php database:update
. Using Tiki with an incorrect database version usually provokes errors. If you have shell (SSH) access, you can also use the following, on the command line, from the root of your Tiki installation: php console.php database:update

My Webcity technical support advises
"I am unsure why it is reporting this error, if this CMS runs on Mysql as the
current software on this server is fairly recent here are its details.
PHP Version 5.6.14
MySQL Version 5.5.46-cll"

Tiki installation is at http://www.chaplaincyacademy.com/tiki10

How should I proceed?

posts: 3577

It looks like you did not updgrade your Tiki database to 12.6, that's why you're getting the message.

Complete the Tiki installer (tiki-install.php) and select the UPGRADE option. Please see the docs for details.

You might also find my tutorial helpful.

HTH,

- Rick | My Tiki Blog | My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.
posts: 41

Thanks for the prompt response.

I upgraded to 12.6 using Softaculous and it is reporting that 12.6 is installed.
I will check your link when I get back in a few hours.

posts: 41

I have cleared the cache on the Tiki and my browser.
I am proceeding cautiously and backing up my database before trying a reinstall of 12.6.
I will wait for a response before proceeding as I prefer to let softaculous do the work unless there is something I have to work around.

It gives me this message

As a security precaution, the Tiki Installer has been disabled. To re-enable the installer:
Use your file manager application to find the directory where you have unpacked your Tiki and remove the lock file which was created in the db folder.
Re-run tiki-install.php.

posts: 3577

For your protection, you have to "unlock" the installer before re-running it. You have to remove the ../db/lock file.

Please review the upgrade document, especially step 8(b), for more information.

HTH,

- Rick | My Tiki Blog | My Tiki UserPage

Why be a dummy? Get smarty! TikiForSmarties.com
Tiki for Smarties, your source for the best (and only) Tiki books, guides, and tutorials.

posts: 41

Thanks Rick,

I removed the lock file and ran the installer and the upgrade worked. It seems that Softaculous does not "know" about the lock file as the installer reported it was upgrading from 12.3 to 12.6, and I had previously upgraded from 12.3 to 12.4, and that must not have worked.


Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.